[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <51b660f3-8145-d35e-87b4-d9ac0623606d@kernel.org>
Date: Fri, 7 Jul 2023 08:50:01 +0900
From: Damien Le Moal <dlemoal@...nel.org>
To: Andreas Hindborg <nmi@...aspace.dk>, Ming Lei <ming.lei@...hat.com>
Cc: open list <linux-kernel@...r.kernel.org>,
"open list:BLOCK LAYER" <linux-block@...r.kernel.org>,
Andreas Hindborg <a.hindborg@...sung.com>,
Minwoo Im <minwoo.im.dev@...il.com>,
Matias Bjorling <Matias.Bjorling@....com>,
gost.dev@...sung.com, Jens Axboe <axboe@...nel.dk>,
Aravind Ramesh <Aravind.Ramesh@....com>,
Johannes Thumshirn <jth@...nel.org>,
Hans Holmberg <Hans.Holmberg@....com>,
Christoph Hellwig <hch@...radead.org>
Subject: Re: [PATCH v6 1/3] ublk: add opcode offsets for DRV_IN/DRV_OUT
On 7/6/23 22:09, Andreas Hindborg wrote:
> From: Andreas Hindborg <a.hindborg@...sung.com>
>
> Ublk zoned storage support relies on DRV_IN handling for zone report.
> Prepare for this change by adding offsets for the DRV_IN/DRV_OUT commands.
>
> Also add parenthesis to existing opcodes for better macro hygiene.
>
> Signed-off-by: Andreas Hindborg <a.hindborg@...sung.com>
> ---
> include/uapi/linux/ublk_cmd.h | 18 ++++++++++++++----
> 1 file changed, 14 insertions(+), 4 deletions(-)
>
> diff --git a/include/uapi/linux/ublk_cmd.h b/include/uapi/linux/ublk_cmd.h
> index 4b8558db90e1..2ebb8d5d827a 100644
> --- a/include/uapi/linux/ublk_cmd.h
> +++ b/include/uapi/linux/ublk_cmd.h
> @@ -229,12 +229,22 @@ struct ublksrv_ctrl_dev_info {
> __u64 reserved2;
> };
>
> -#define UBLK_IO_OP_READ 0
> +#define UBLK_IO_OP_READ 0
> #define UBLK_IO_OP_WRITE 1
> #define UBLK_IO_OP_FLUSH 2
> -#define UBLK_IO_OP_DISCARD 3
> -#define UBLK_IO_OP_WRITE_SAME 4
> -#define UBLK_IO_OP_WRITE_ZEROES 5
> +#define UBLK_IO_OP_DISCARD 3
> +#define UBLK_IO_OP_WRITE_SAME 4
> +#define UBLK_IO_OP_WRITE_ZEROES 5
> +/*
> + * Passthrough (driver private) operation codes range between
This is unclear... Here, what does "driver" refer to ? If it is the ublk
kernel driver, than these commands should not be defined in the uapi
header file, they should be defined in drivers/block/ublk.h. However, if
these are for the user space driver, like all the other operations, then
let's clearly state so. But then, I still not understand why these need
a different naming pattern using the "__UBLK" prefix...
> + * __UBLK_IO_OP_DRV_IN_START and __UBLK_IO_OP_DRV_IN_END for REQ_OP_DRV_IN type
> + * operations and between __UBLK_IO_OP_DRV_OUT_START and
> + * __UBLK_IO_OP_DRV_OUT_END for REQ_OP_DRV_OUT type operations.
> + */
> +#define __UBLK_IO_OP_DRV_IN_START 32
> +#define __UBLK_IO_OP_DRV_IN_END 96
> +#define __UBLK_IO_OP_DRV_OUT_START __UBLK_IO_OP_DRV_IN_END
> +#define __UBLK_IO_OP_DRV_OUT_END 160
>
> #define UBLK_IO_F_FAILFAST_DEV (1U << 8)
> #define UBLK_IO_F_FAILFAST_TRANSPORT (1U << 9)
--
Damien Le Moal
Western Digital Research
Powered by blists - more mailing lists