[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <SA1PR11MB67344CAD2EF26F37AF06A8B2A82CA@SA1PR11MB6734.namprd11.prod.outlook.com>
Date: Thu, 6 Jul 2023 07:25:03 +0000
From: "Li, Xin3" <xin3.li@...el.com>
To: Peter Zijlstra <peterz@...radead.org>
CC: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"kvm@...r.kernel.org" <kvm@...r.kernel.org>,
"x86@...nel.org" <x86@...nel.org>,
"tglx@...utronix.de" <tglx@...utronix.de>,
"mingo@...hat.com" <mingo@...hat.com>,
"bp@...en8.de" <bp@...en8.de>,
"dave.hansen@...ux.intel.com" <dave.hansen@...ux.intel.com>,
"hpa@...or.com" <hpa@...or.com>,
"Christopherson,, Sean" <seanjc@...gle.com>,
"pbonzini@...hat.com" <pbonzini@...hat.com>
Subject: RE: [PATCH] x86/trapnr: Add event type macros to <asm/trapnr.h>
> > +/*
> > + * Event type codes used by both Intel VT-x and FRED */
> > +/* Maskable external interrupt */
> > +#define EVENT_TYPE_HWINT 0
> > +#define EVENT_TYPE_RESERVED 1
> > +#define EVENT_TYPE_NMI 2
> > +/* Hardware exceptions (e.g., page fault) */
> > +#define EVENT_TYPE_HWFAULT 3
> > +/* Software interrupt (INT n) */
> > +#define EVENT_TYPE_SWINT 4
> > +/* INT1 (ICEBP) */
> > +#define EVENT_TYPE_PRIVSW 5
> > +/* Software exception (INT3 or INTO) */
> > +#define EVENT_TYPE_SWFAULT 6
> > +/* VT-x MTF or FRED SYSCALL/SYSENTER */
> > +#define EVENT_TYPE_OTHER 7
>
> So I know tglx hates on tail comments, but I find the below *MUCH* more readable
> than the above horror show.
Agree, sometimes a tail comment looks much better.
Maybe tglx could give more specific directions on when it's okay to use
tail comments.
Thanks!
Xin
Powered by blists - more mailing lists