[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1a970ae7-73fd-71e4-770e-120295454753@infradead.org>
Date: Wed, 5 Jul 2023 18:07:41 -0700
From: Randy Dunlap <rdunlap@...radead.org>
To: Dmitry Torokhov <dmitry.torokhov@...il.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Input: gameport - use IS_REACHABLE() instead of
open-coding it
On 7/5/23 17:30, Dmitry Torokhov wrote:
> Replace an open-coded preprocessor conditional with an equivalent helper.
>
> Signed-off-by: Dmitry Torokhov <dmitry.torokhov@...il.com>
Reviewed-by: Randy Dunlap <rdunlap@...radead.org>
Thanks.
> ---
> include/linux/gameport.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/include/linux/gameport.h b/include/linux/gameport.h
> index 0a221e768ea4..07e370113b2b 100644
> --- a/include/linux/gameport.h
> +++ b/include/linux/gameport.h
> @@ -63,7 +63,7 @@ struct gameport_driver {
> int gameport_open(struct gameport *gameport, struct gameport_driver *drv, int mode);
> void gameport_close(struct gameport *gameport);
>
> -#if defined(CONFIG_GAMEPORT) || (defined(MODULE) && defined(CONFIG_GAMEPORT_MODULE))
> +#if IS_REACHABLE(CONFIG_GAMEPORT)
>
> void __gameport_register_port(struct gameport *gameport, struct module *owner);
> /* use a define to avoid include chaining to get THIS_MODULE */
--
~Randy
Powered by blists - more mailing lists