[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230713163626.31338-19-jim.cromie@gmail.com>
Date: Thu, 13 Jul 2023 10:36:23 -0600
From: Jim Cromie <jim.cromie@...il.com>
To: jbaron@...mai.com, daniel.vetter@...ll.ch,
linux-kernel@...r.kernel.org, dri-devel@...ts.freedesktop.org,
amd-gfx@...ts.freedesktop.org, intel-gvt-dev@...ts.freedesktop.org,
intel-gfx@...ts.freedesktop.org
Cc: jani.nikula@...el.com, ville.syrjala@...ux.intel.com,
seanpaul@...omium.org, robdclark@...il.com,
gregkh@...uxfoundation.org, Jim Cromie <jim.cromie@...il.com>,
Luc Van Oostenryck <luc.vanoostenryck@...il.com>,
Nathan Chancellor <nathan@...nel.org>,
Nick Desaulniers <ndesaulniers@...gle.com>,
Tom Rix <trix@...hat.com>, linux-sparse@...r.kernel.org,
llvm@...ts.linux.dev
Subject: [PATCH v4 18/21] compiler.h: RFC - s/__LINE__/__COUNTER__/ in __UNIQUE_ID fallback
We currently have 3 defns for __UNIQUE_ID(); gcc and clang are using
__COUNTER__ for real uniqueness, 3rd just uses __LINE__, which should
fail on this (and harder to avoid situations):
DECLARE_FOO(); DECLARE_FOO();
Its 2023, can we haz a no-fallback __UNIQUE_ID ?
NOTE:
This also changes __UNIQUE_ID_ to _kaUID_. Ive been getting
lkp-reports of collisions on names which should be unique; this
shouldnt happen on gcc & clang, but does on some older ones, on some
platforms, on some allyes & rand-configs. Like this:
mips64-linux-ld:
drivers/gpu/drm/display/drm_dp_helper.o:(__dyndbg_class_users+0x0):
multiple definition of `__UNIQUE_ID_ddebug_class_user405';
drivers/gpu/drm/drm_gem_shmem_helper.o:(__dyndbg_class_users+0x0):
first defined here
Like above, the collision reports appear to always be 3-digit
counters, which look like line-numbers. Changing to _kaUID_ in this
defn should make it more obvious (in *.i file) when a fallback has
happened. To be clear, I havent seen it yet. Nor have I seen the
multiple-defn problem above since adding this patch.
Lets see what lkp-robot says about this.
CC: Luc Van Oostenryck <luc.vanoostenryck@...il.com> (maintainer:SPARSE CHECKER)
CC: Nathan Chancellor <nathan@...nel.org> (supporter:CLANG/LLVM BUILD SUPPORT)
CC: Nick Desaulniers <ndesaulniers@...gle.com> (supporter:CLANG/LLVM BUILD SUPPORT)
CC: Tom Rix <trix@...hat.com> (reviewer:CLANG/LLVM BUILD SUPPORT)
CC: linux-sparse@...r.kernel.org (open list:SPARSE CHECKER)
CC: linux-kernel@...r.kernel.org (open list)
CC: llvm@...ts.linux.dev (open list:CLANG/LLVM BUILD SUPPORT)
Signed-off-by: Jim Cromie <jim.cromie@...il.com>
---
include/linux/compiler.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/compiler.h b/include/linux/compiler.h
index d7779a18b24f..677d6c47cd9e 100644
--- a/include/linux/compiler.h
+++ b/include/linux/compiler.h
@@ -177,9 +177,9 @@ void ftrace_likely_update(struct ftrace_likely_data *f, int val,
__asm__ ("" : "=r" (var) : "0" (var))
#endif
-/* Not-quite-unique ID. */
+/* JFTI: to fix Not-quite-unique ID */
#ifndef __UNIQUE_ID
-# define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __LINE__)
+# define __UNIQUE_ID(prefix) __PASTE(__PASTE(_kaUID_, prefix), __COUNTER__)
#endif
/**
--
2.41.0
Powered by blists - more mailing lists