[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZLB2Ro55dKGElB9B@google.com>
Date: Thu, 13 Jul 2023 15:10:14 -0700
From: Sean Christopherson <seanjc@...gle.com>
To: isaku.yamahata@...el.com
Cc: kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
isaku.yamahata@...il.com, Paolo Bonzini <pbonzini@...hat.com>,
erdemaktas@...gle.com, Sagi Shahar <sagis@...gle.com>,
David Matlack <dmatlack@...gle.com>,
Kai Huang <kai.huang@...el.com>,
Zhi Wang <zhi.wang.linux@...il.com>, chen.bo@...el.com,
linux-coco@...ts.linux.dev,
Chao Peng <chao.p.peng@...ux.intel.com>,
Ackerley Tng <ackerleytng@...gle.com>,
Vishal Annapurve <vannapurve@...gle.com>,
Michael Roth <michael.roth@....com>,
Yuan Yao <yuan.yao@...ux.intel.com>,
Yu Zhao <yuzhao@...gle.com>
Subject: Re: [RFC PATCH v3 09/11] KVM: Add new members to struct kvm_gfn_range
to operate on
+Yu
On Wed, Jun 28, 2023, isaku.yamahata@...el.com wrote:
> void kvm_mmu_init_memslot_memory_attributes(struct kvm *kvm,
> diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h
> index 1a47cedae8a1..5ca0c8ee4292 100644
> --- a/include/linux/kvm_host.h
> +++ b/include/linux/kvm_host.h
> @@ -260,7 +260,13 @@ struct kvm_gfn_range {
> struct kvm_memory_slot *slot;
> gfn_t start;
> gfn_t end;
> - pte_t pte;
> + union {
> + unsigned long attributes;
> + pte_t pte;
> + unsigned long callback_arg; /* needs a better name */
> + };
Making the union needs to be done in a separate patch. And coming back to this
with fresh eyes, I think it makes sense to give the union a name. I think an
anonymous union is actually worse in the long run, and there aren't _that_ many
instances to update. E.g. that way a single build-time assertion can capture
all uses, and it makes it more obvious that the usage is poking into a union.
I'll post a patch separately so that it can be picked up for the MGLRU series
(and maybe even merged ahead of both).
Powered by blists - more mailing lists