[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230713115412.GI3138667@hirez.programming.kicks-ass.net>
Date: Thu, 13 Jul 2023 13:54:12 +0200
From: Peter Zijlstra <peterz@...radead.org>
To: Jens Axboe <axboe@...nel.dk>
Cc: io-uring@...r.kernel.org, linux-kernel@...r.kernel.org,
tglx@...utronix.de, mingo@...hat.com, andres@...razel.de
Subject: Re: [PATCH 8/8] io_uring: add support for vectored futex waits
On Wed, Jul 12, 2023 at 10:20:17AM -0600, Jens Axboe wrote:
> int io_futex_prep(struct io_kiocb *req, const struct io_uring_sqe *sqe);
> +int io_futexv_prep(struct io_kiocb *req, const struct io_uring_sqe *sqe);
> int io_futex_wait(struct io_kiocb *req, unsigned int issue_flags);
> +int io_futex_waitv(struct io_kiocb *req, unsigned int issue_flags);
> int io_futex_wake(struct io_kiocb *req, unsigned int issue_flags);
That's an inconsistent naming convention.. I'll stare at the rest later.
Powered by blists - more mailing lists