[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5c10619b-14cb-a765-488c-8fbda857b4c2@wanadoo.fr>
Date: Mon, 17 Jul 2023 21:32:15 +0200
From: Christophe JAILLET <christophe.jaillet@...adoo.fr>
To: Saravana Kannan <saravanak@...gle.com>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J. Wysocki" <rafael@...nel.org>,
linux-kernel@...r.kernel.org, kernel-janitors@...r.kernel.org
Subject: Re: [PATCH] driver core: Fix an error handling path in
fw_devlink_create_devlink()
Le 17/07/2023 à 20:57, Saravana Kannan a écrit :
> On Mon, Jul 17, 2023 at 11:26 AM Christophe JAILLET
> <christophe.jaillet@...adoo.fr> wrote:
>>
>> All error handling paths go to 'out', except this one. Be consistent and
>> also branch to 'out' here.
>>
>> Fixes: 74c782cff77b ("driver core: fw_devlink: Handle suppliers that don't use driver core")
>> Signed-off-by: Christophe JAILLET <christophe.jaillet@...adoo.fr>
>> ---
>> /!\ Speculative /!\
>>
>> This patch is based on analysis of the surrounding code and should be
>> reviewed with care !
>>
>> If the patch is wrong, maybe a comment in the code could explain why.
>>
>> /!\ Speculative /!\
>
> Looks okay to me, but I'd rather not much around the code for a
> subjective preference. The existing code also avoids the pointless
> put_device() and personally is easier to read (ok, nothing more of
> relevance is done after this return) than trying to follow the
> execution to the out and then realizing the put_device() is a NOP,
> etc. It also means future changes to "out" will need to accommodate
> for this path that doesn't really need the "out" path.
>
> -Saravana
Agreed,
I didn't realized that this code was executed only if "if (sup_dev)"
fails, so only if sup_dev is NULL.
Sorry for the noise.
CJ
>
>> ---
>> drivers/base/core.c | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/base/core.c b/drivers/base/core.c
>> index 3dff5037943e..854c1fab742c 100644
>> --- a/drivers/base/core.c
>> +++ b/drivers/base/core.c
>> @@ -2107,7 +2107,8 @@ static int fw_devlink_create_devlink(struct device *con,
>> fwnode_ancestor_init_without_drv(sup_handle)) {
>> dev_dbg(con, "Not linking %pfwf - might never become dev\n",
>> sup_handle);
>> - return -EINVAL;
>> + ret = -EINVAL;
>> + goto out;
>> }
>>
>> ret = -EAGAIN;
>> --
>> 2.34.1
>>
>
Powered by blists - more mailing lists