lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <9a64823c-f475-ef2d-aba8-a674e4b27cba@quicinc.com>
Date:   Mon, 17 Jul 2023 10:47:38 +0530
From:   Praveenkumar I <quic_ipkumar@...cinc.com>
To:     Konrad Dybcio <konrad.dybcio@...aro.org>, <amitk@...nel.org>,
        <thara.gopinath@...il.com>, <agross@...nel.org>,
        <andersson@...nel.org>, <rafael@...nel.org>,
        <daniel.lezcano@...aro.org>, <rui.zhang@...el.com>,
        <robh+dt@...nel.org>, <krzysztof.kozlowski+dt@...aro.org>,
        <conor+dt@...nel.org>, <linux-pm@...r.kernel.org>,
        <linux-arm-msm@...r.kernel.org>, <devicetree@...r.kernel.org>,
        <linux-kernel@...r.kernel.org>
CC:     <quic_varada@...cinc.com>
Subject: Re: [PATCH v3 1/5] thermal/drivers/tsens: Add TSENS enable and
 calibration support for V2


On 7/15/2023 7:35 PM, Konrad Dybcio wrote:
> On 13.07.2023 07:27, Praveenkumar I wrote:
>> SoCs without RPM have to enable sensors and calibrate from the kernel.
>> Though TSENS IP supports 16 sensors, not all are used. So used hw_id
>> to enable the relevant sensors.
>>
>> Added new calibration function for V2 as the tsens.c calib function
>> only supports V1.
>>
>> Signed-off-by: Praveenkumar I <quic_ipkumar@...cinc.com>
>> ---
> [...]
>
>>   
>>   /* ----- SROT ------ */
>>   #define SROT_HW_VER_OFF	0x0000
>>   #define SROT_CTRL_OFF		0x0004
>> +#define SROT_MEASURE_PERIOD	0x0008
>> +#define SROT_Sn_CONVERSION	0x0060
>> +#define V2_SHIFT_DEFAULT	0x0003
>> +#define V2_SLOPE_DEFAULT	0x0cd0
>> +#define V2_CZERO_DEFAULT	0x016a
>> +#define ONE_PT_SLOPE		0x0cd0
>> +#define TWO_PT_SHIFTED_GAIN	921600
>> +#define ONE_PT_CZERO_CONST	94
>> +#define SENSOR_CONVERSION(n)	(((n) * 4) + SROT_Sn_CONVERSION)
>> +#define CONVERSION_SLOPE_SHIFT	10
>> +#define CONVERSION_SHIFT_SHIFT	23
> Please define bitfields with GENMASK() and use FIELD_PREP/GET() helpers
Sure, will change in the next patch.
>
>>   
>>   /* ----- TM ------ */
>>   #define TM_INT_EN_OFF			0x0004
>> @@ -59,6 +71,11 @@ static const struct reg_field tsens_v2_regfields[MAX_REGFIELDS] = {
>>   	/* CTRL_OFF */
>>   	[TSENS_EN]     = REG_FIELD(SROT_CTRL_OFF,    0,  0),
>>   	[TSENS_SW_RST] = REG_FIELD(SROT_CTRL_OFF,    1,  1),
>> +	[SENSOR_EN]    = REG_FIELD(SROT_CTRL_OFF,    3,  18),
>> +	[CODE_OR_TEMP] = REG_FIELD(SROT_CTRL_OFF,    21, 21),
>> +
>> +	/* MAIN_MEASURE_PERIOD */
>> +	[MAIN_MEASURE_PERIOD] = REG_FIELD(SROT_MEASURE_PERIOD, 0, 7),
>>   
>>   	/* ----- TM ------ */
>>   	/* INTERRUPT ENABLE */
>> @@ -104,6 +121,130 @@ static const struct reg_field tsens_v2_regfields[MAX_REGFIELDS] = {
>>   	[TRDY] = REG_FIELD(TM_TRDY_OFF, 0, 0),
>>   };
>>   
>> +static int tsens_v2_calibrate_sensor(struct device *dev, struct tsens_sensor *sensor,
>> +				     struct regmap *map,  u32 mode, u32 base0, u32 base1)
>> +{
>> +	u32 slope, czero, val;
>> +	char name[15];
> What's the rationale behind choosing 15 here?
Chose 15 when I had the sensor data name as s[0-9]+_offset. Right now 
sensor data name is changed to s[0-9]+, I can reduce it to 8 based on 
"mode0".
>
>> +	int ret;
>> +
> [...]
>
>> +static int tsens_v2_calibration(struct tsens_priv *priv)
>> +{
>> +	struct device *dev = priv->dev;
>> +	u32 mode, base0, base1;
>> +	int i, ret;
>> +
>> +	if (priv->num_sensors > MAX_SENSORS)
>> +		return -EINVAL;
>> +
>> +	ret = nvmem_cell_read_variable_le_u32(priv->dev, "mode", &mode);
>> +	if (ret == -ENOENT)
>> +		dev_warn(priv->dev, "Calibration data not present in DT\n");
> I think bindings don't allow that anyway
Updated the bindings in [v3 2/5] and with that it is allowing.
>
>> +	if (ret < 0)
>> +		return ret;
>> +
>> +	dev_dbg(priv->dev, "calibration mode is %d\n", mode);
>> +
>> +	ret = nvmem_cell_read_variable_le_u32(priv->dev, "base0", &base0);
>> +	if (ret < 0)
>> +		return ret;
>> +
>> +	ret = nvmem_cell_read_variable_le_u32(priv->dev, "base1", &base1);
>> +	if (ret < 0)
>> +		return ret;
>> +
>> +	/* Calibrate each sensor */
>> +	for (i = 0; i < priv->num_sensors; i++) {
>> +		ret = tsens_v2_calibrate_sensor(dev, &priv->sensor[i], priv->srot_map,
>> +						mode, base0, base1);
>> +		if (ret < 0)
>> +			return ret;
>> +	}
>> +
>> +	return 0;
>> +}
>> +
>> +static int __init init_tsens_v2_no_rpm(struct tsens_priv *priv)
>> +{
>> +	int i, ret;
>> +	u32 val = 0;
>> +	struct device *dev = priv->dev;
> Reverse-Christmas-tree, please.
Sure, will update in next patch.
>
>> +
>> +	ret = init_common(priv);
>> +	if (ret < 0)
>> +		return ret;
>> +
>> +	priv->rf[CODE_OR_TEMP] = devm_regmap_field_alloc(dev, priv->srot_map,
>> +							 priv->fields[CODE_OR_TEMP]);
>> +	if (IS_ERR(priv->rf[CODE_OR_TEMP]))
>> +		return PTR_ERR(priv->rf[CODE_OR_TEMP]);
>> +
>> +	priv->rf[MAIN_MEASURE_PERIOD] = devm_regmap_field_alloc(dev, priv->srot_map,
>> +								priv->fields[MAIN_MEASURE_PERIOD]);
>> +	if (IS_ERR(priv->rf[MAIN_MEASURE_PERIOD]))
>> +		return PTR_ERR(priv->rf[MAIN_MEASURE_PERIOD]);
>> +
>> +	regmap_field_write(priv->rf[TSENS_SW_RST], 0x1);
>> +
>> +	/* Update measure period to 2ms */
> What's the unit? Can we name the 0x1 value?
Deci-Celcius is supported in hardware.
Sure, will name the values in the next patch.
>
>> +	regmap_field_write(priv->rf[MAIN_MEASURE_PERIOD], 0x1);
>> +
>> +	/* Enable available sensors */
>> +	for (i = 0; i < priv->num_sensors; i++)
>> +		val |= 1 << priv->sensor[i].hw_id;
>> +
>> +	regmap_field_write(priv->rf[SENSOR_EN], val);
>> +
>> +	/* Real temperature format */
> What does that mean?
Result format can be selected via the below write and supported format 
is ADC Code or Temperature in deci-celcius. Added a comment to mention 
selecting temperature format.
Will name the value and remove the comment.
>
>> +	regmap_field_write(priv->rf[CODE_OR_TEMP], 0x1);
>> +
>> +	regmap_field_write(priv->rf[TSENS_SW_RST], 0x0);
>> +
>> +	/* Enable TSENS */
>> +	regmap_field_write(priv->rf[TSENS_EN], 0x1);
> It would be really nice if you could provide the names of all these
> magic values.
Sure, will update in the next patch.
>
> Konrad
>> +
>> +	return 0;
>> +}
>> +
>>   static const struct tsens_ops ops_generic_v2 = {
>>   	.init		= init_common,
>>   	.get_temp	= get_temp_tsens_valid,
>> diff --git a/drivers/thermal/qcom/tsens.c b/drivers/thermal/qcom/tsens.c
>> index 98c356acfe98..9dc0c2150948 100644
>> --- a/drivers/thermal/qcom/tsens.c
>> +++ b/drivers/thermal/qcom/tsens.c
>> @@ -974,7 +974,7 @@ int __init init_common(struct tsens_priv *priv)
>>   	ret = regmap_field_read(priv->rf[TSENS_EN], &enabled);
>>   	if (ret)
>>   		goto err_put_device;
>> -	if (!enabled) {
>> +	if (!enabled && (tsens_version(priv) != VER_2_X_NO_RPM)) {
>>   		dev_err(dev, "%s: device not enabled\n", __func__);
>>   		ret = -ENODEV;
>>   		goto err_put_device;
>> diff --git a/drivers/thermal/qcom/tsens.h b/drivers/thermal/qcom/tsens.h
>> index 2805de1c6827..b2e8f0f2b466 100644
>> --- a/drivers/thermal/qcom/tsens.h
>> +++ b/drivers/thermal/qcom/tsens.h
>> @@ -35,6 +35,7 @@ enum tsens_ver {
>>   	VER_0_1,
>>   	VER_1_X,
>>   	VER_2_X,
>> +	VER_2_X_NO_RPM,
>>   };
>>   
>>   enum tsens_irq_type {
>> @@ -168,6 +169,8 @@ enum regfield_ids {
>>   	TSENS_SW_RST,
>>   	SENSOR_EN,
>>   	CODE_OR_TEMP,
>> +	/* MEASURE_PERIOD */
>> +	MAIN_MEASURE_PERIOD,
>>   
>>   	/* ----- TM ------ */
>>   	/* TRDY */
--
Thanks,
Praveenkumar

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ