[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230726082245.550929-1-angelogioacchino.delregno@collabora.com>
Date: Wed, 26 Jul 2023 10:22:39 +0200
From: AngeloGioacchino Del Regno
<angelogioacchino.delregno@...labora.com>
To: chunkuang.hu@...nel.org
Cc: p.zabel@...gutronix.de, airlied@...il.com, daniel@...ll.ch,
matthias.bgg@...il.com, angelogioacchino.delregno@...labora.com,
dri-devel@...ts.freedesktop.org,
linux-mediatek@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, kernel@...labora.com,
fshao@...omium.org
Subject: [PATCH v3 0/6] drm/mediatek: Small mtk-dpi cleanups
Changes in v3:
- Fixed removal of mtk_dpi pointer in mtk_dpi_remove on patch [1/6]
instead of patch [3/6]; thanks CK Hu!
Changes in v2:
- Removed drm_bridge_remove() call in patch 1
- Added dev_err_probe print to devm_drm_of_get_bridge()
call error handling
- Switched to devm_platform_ioremap_resource() to remove
the useless pointer to struct resource in probe function
- Added a commit to compress struct of_device_id entries
- Added a commit to switch to .remove_new() callback
This is a small cleanup of the mtk-dpi driver, switching it to devm
variants where possible and where it made sense, and reducing lines
while retaining and improving human readability.
AngeloGioacchino Del Regno (6):
drm/mediatek: mtk_dpi: Simplify with devm_drm_bridge_add()
drm/mediatek: mtk_dpi: Simplify with dev_err_probe()
drm/mediatek: mtk_dpi: Switch to devm_drm_of_get_bridge()
drm/mediatek: mtk_dpi: Switch to .remove_new() void callback
drm/mediatek: mtk_dpi: Use devm_platform_ioremap_resource()
drm/mediatek: mtk_dpi: Compress struct of_device_id entries
drivers/gpu/drm/mediatek/mtk_dpi.c | 100 +++++++++--------------------
1 file changed, 32 insertions(+), 68 deletions(-)
--
2.41.0
Powered by blists - more mailing lists