[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230803102446.8edf94acc77e81ab2e09cee3@linux-foundation.org>
Date: Thu, 3 Aug 2023 10:24:46 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Jani Nikula <jani.nikula@...el.com>,
Imre Deak <imre.deak@...el.com>,
Philipp Zabel <p.zabel@...gutronix.de>,
Andi Shyti <andi.shyti@...ux.intel.com>,
Jiri Slaby <jirislaby@...nel.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Alexey Dobriyan <adobriyan@...il.com>,
intel-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
linux-kernel@...r.kernel.org, linux-serial@...r.kernel.org,
linux-fbdev@...r.kernel.org,
Jani Nikula <jani.nikula@...ux.intel.com>,
Joonas Lahtinen <joonas.lahtinen@...ux.intel.com>,
Rodrigo Vivi <rodrigo.vivi@...el.com>,
Tvrtko Ursulin <tvrtko.ursulin@...ux.intel.com>,
David Airlie <airlied@...il.com>,
Daniel Vetter <daniel@...ll.ch>, Helge Deller <deller@....de>,
Rasmus Villemoes <linux@...musvillemoes.dk>
Subject: Re: [PATCH v4 1/1] drm/i915: Move abs_diff() to math.h
On Thu, 3 Aug 2023 16:19:18 +0300 Andy Shevchenko <andriy.shevchenko@...ux.intel.com> wrote:
> abs_diff() belongs to math.h. Move it there.
> This will allow others to use it.
>
> ...
>
> --- a/include/linux/math.h
> +++ b/include/linux/math.h
> @@ -155,6 +155,13 @@ __STRUCT_FRACT(u32)
> __builtin_types_compatible_p(typeof(x), unsigned type), \
> ({ signed type __x = (x); __x < 0 ? -__x : __x; }), other)
>
> +#define abs_diff(a, b) ({ \
> + typeof(a) __a = (a); \
> + typeof(b) __b = (b); \
> + (void)(&__a == &__b); \
> + __a > __b ? (__a - __b) : (__b - __a); \
> +})
Can we document it please?
Also, the open-coded type comparison could be replaced with __typecheck()?
And why the heck isn't __typecheck() in typecheck.h, to be included by
minmax.h.
etcetera. Sigh. I'll grab it, but please at least send along some
kerneldoc?
Powered by blists - more mailing lists