[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZNDKtwO3tWNIFIhz@hovoldconsulting.com>
Date: Mon, 7 Aug 2023 12:43:03 +0200
From: Johan Hovold <johan@...nel.org>
To: Konrad Dybcio <konrad.dybcio@...aro.org>
Cc: Stanimir Varbanov <stanimir.k.varbanov@...il.com>,
Vikash Garodia <quic_vgarodia@...cinc.com>,
Bryan O'Donoghue <bryan.odonoghue@...aro.org>,
Andy Gross <agross@...nel.org>,
Bjorn Andersson <andersson@...nel.org>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Conor Dooley <conor+dt@...nel.org>,
Marijn Suijten <marijn.suijten@...ainline.org>,
Konrad Dybcio <konradybcio@...nel.org>,
linux-media@...r.kernel.org, linux-arm-msm@...r.kernel.org,
devicetree@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 4/6] media: platform: venus: Add optional LLCC path
On Fri, Aug 04, 2023 at 10:09:11PM +0200, Konrad Dybcio wrote:
> @@ -479,12 +488,18 @@ static __maybe_unused int venus_runtime_suspend(struct device *dev)
> if (ret)
> goto err_cpucfg_path;
>
> + ret = icc_set_bw(core->llcc_path, 0, 0);
> + if (ret)
> + goto err_llcc_path;
> +
> ret = icc_set_bw(core->video_path, 0, 0);
> if (ret)
> goto err_video_path;
>
> return ret;
>
> +err_llcc_path:
> + icc_set_bw(core->video_path, kbps_to_icc(20000), 0);
This looks wrong; you should not try to restore the video path bw which
you have not yet updated here.
Also error labels should be named after what they do, not after where
you jump from (e.g. to avoid mistakes like the above). Perhaps you can
clean up the existing labels before adding the new one.
> err_video_path:
> icc_set_bw(core->cpucfg_path, kbps_to_icc(1000), 0);
> err_cpucfg_path:
Johan
Powered by blists - more mailing lists