lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 09 Aug 2023 01:38:27 +0200
From:   Konrad Dybcio <konrad.dybcio@...aro.org>
To:     AngeloGioacchino Del Regno 
        <angelogioacchino.delregno@...labora.com>,
        Dmitry Torokhov <dmitry.torokhov@...il.com>,
        Rob Herring <robh+dt@...nel.org>,
        Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
        Conor Dooley <conor+dt@...nel.org>,
        Del Regno <angelogioacchino.delregno@...labora.com>,
        Henrik Rydberg <rydberg@...math.org>
Cc:     Marijn Suijten <marijn.suijten@...ainline.org>,
        linux-input@...r.kernel.org, devicetree@...r.kernel.org,
        linux-kernel@...r.kernel.org,
        Krzysztof Kozlowski <krzk@...nel.org>,
        Rob Herring <robh@...nel.org>,
        Konrad Dybcio <konrad.dybcio@...aro.org>,
        Dang Huynh <danct12@...eup.net>,
        Amit Pundir <amit.pundir@...aro.org>
Subject: [PATCH v10 0/2] Add Novatek NT36xxx touchscreen driver

I am taking over this series from Angelo, as he's moved on to other
things, but there are still devices out there (and being made)
utilizing this class of ICs.

This patch series has been tested against the following devices:
 - Sony Xperia 10        (SDM630 Ganges Kirin)
 - Sony Xperia 10 Plus   (SDM636 Ganges Mermaid)

Changes in v2:
- Fixed sparse warnings from lkp kernel test robot

Changes in v3 (as requested by Dmitry Torokhov):
- Using shorthand u16/u32 (sorry for the overlook!)
- Now using more input and touchscreen APIs
- Fixed useless workqueue involvements
- Removed useless locking
- Switched reads and writes to use regmap
- Moved header contents to nt36xxx.c
- Fixed reset gpio handling
- Other cleanups
- P.S.: Thanks, Dmitry!

Changes in v4:
- Fixed regmap read length for CRC_ERR_FLAG final check
- Fixed YAML binding, as requested by Krzysztof Kozlowski

Changes in v5:
- Replaced subsystem maintainer's name with .. mine,
  usage of additionalProperties to unevaluatedProperties
  and a typo fix for reset-gpios as per Rob Herring's review
- Changed compatible string as per Krzysztof K. request
- Renamed the novatek,nt36xxx.yaml file to just nt36xxx.yaml
  in order to now reflect the driver name instead of the DT
  compatible
- Fixed blank line at EOF

Changes in v6:
- Removed include of_gpio.h, added mod_devicetable.h and
  gpio/consumer.h
- Added kerneldoc to relevant functions/enum
- Used traditional patterns for error checking where possible
- Documented calls to usleep/msleep
- Using be16_to_cpu / get_unaligned_be16 where possible
- Added helper for CRC error check on retrieved buffer
- Decreased indentation in the CRC reboot recovery function
- Removed instances of error code sum
- Dropped all likely/unlikely optimization as per request
- Removed redundant reset_gpio checks
- Dropped of_match_ptr and ifdefs for CONFIG_OF

Changes in v7:
- Fixed typo in nt36xxx.c

Changes in v8:
- Fixed typo reset-gpio -> reset-gpios in dt-bindings

Changes in v9:
- Includes are now sorted
- Used proposed sizeof variable instead of sizeof type
- Fixed a return value check for common pattern
- Added NULL check to devm_kasprintf call
- Returning ret on probe function to be consistent

Changes in v10:
- Take over this series from Angelo
- Update Angelo's e-mail address
- Rebase over linux-next
- Pick up tags
- Drop patch adding novatek vendor prefix (it's already there)
- Reword the bindings title and commit title (bindings describe the
  hardware yada yada)
- Solve trivial checkpatch warnings
- Adapt to i2c_probe arguments changing since 2020
- Open-code nt36xxx_mem_map assignments
- Make inline hex lowercase
- Indent nt36xxx_trim_table with tabs
- Add "-i2c" suffix to the compatible, as these chips also can be
  connected over SPI, keep bindings reviews in good faith
- Don't duplicate enum/struct definitions in .c and .h (how did that go
  unnoticed)
- Fix a couple typos
- Use pm_ptr()
- Use consistent whitespacing for defines
- Remove unused defines
- Include nt36xxx.h from nt36xxx.c (........)
- Re-tested on a Sony Xperia 10
Link to v9: https://lore.kernel.org/linux-input/20201028221302.66583-1-kholk11@gmail.com/

--
2.28.0

---
AngeloGioacchino Del Regno (2):
      dt-bindings: touchscreen: Add binding for Novatek NT36xxx ICs
      Input: Add Novatek NT36xxx touchscreen driver

 .../bindings/input/touchscreen/nt36xxx.yaml        |  59 ++
 drivers/input/touchscreen/Kconfig                  |  12 +
 drivers/input/touchscreen/Makefile                 |   1 +
 drivers/input/touchscreen/nt36xxx.c                | 847 +++++++++++++++++++++
 drivers/input/touchscreen/nt36xxx.h                |  89 +++
 5 files changed, 1008 insertions(+)
---
base-commit: 71cd4fc492ec41e4acd85e98bbf7a13753fc1e03
change-id: 20230808-topic-nt36xxx-a41d0c64d5ae

Best regards,
-- 
Konrad Dybcio <konrad.dybcio@...aro.org>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ