lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 14 Aug 2023 11:14:14 -0700
From:   Sean Christopherson <seanjc@...gle.com>
To:     Shiyuan Gao <gaoshiyuan@...du.com>
Cc:     linux-kernel@...r.kernel.org, kvm@...r.kernel.org, x86@...nel.org,
        pbonzini@...hat.com, tglx@...utronix.de, mingo@...hat.com,
        bp@...en8.de, dave.hansen@...ux.intel.com, hpa@...or.com
Subject: Re: [PATCH] KVM: VMX: Rename vmx_get_max_tdp_level to vmx_get_max_ept_level

On Thu, Aug 10, 2023, Shiyuan Gao wrote:
> In vmx, ept_level looks better than tdp level and is consistent with
> svm get_npt_level().
> 
> Signed-off-by: Shiyuan Gao <gaoshiyuan@...du.com>
> ---
>  arch/x86/kvm/vmx/vmx.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/kvm/vmx/vmx.c b/arch/x86/kvm/vmx/vmx.c
> index df461f387e20..f0cfd1f10a06 100644
> --- a/arch/x86/kvm/vmx/vmx.c
> +++ b/arch/x86/kvm/vmx/vmx.c
> @@ -3350,7 +3350,7 @@ void vmx_set_cr0(struct kvm_vcpu *vcpu, unsigned long cr0)
>  	vmx->emulation_required = vmx_emulation_required(vcpu);
>  }
>  
> -static int vmx_get_max_tdp_level(void)
> +static int vmx_get_max_ept_level(void)
>  {
>  	if (cpu_has_vmx_ept_5levels())
>  		return 5;
> @@ -8526,7 +8526,7 @@ static __init int hardware_setup(void)
>  	 */
>  	vmx_setup_me_spte_mask();
>  
> -	kvm_configure_mmu(enable_ept, 0, vmx_get_max_tdp_level(),
> +	kvm_configure_mmu(enable_ept, 0, vmx_get_max_ept_level(),
>  			  ept_caps_to_lpage_level(vmx_capability.ept));

Anyone else have an opinion on this?  I'm leaning toward applying it, but a small
part of me also kinda likes the "tdp" name (though every time I look at this patch
that part of me gets even smaller...).

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ