[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <111c3142-e20b-3e3c-f107-cbb64a16c2b0@linux.alibaba.com>
Date: Tue, 15 Aug 2023 16:58:04 +0800
From: Baolin Wang <baolin.wang@...ux.alibaba.com>
To: Kemeng Shi <shikemeng@...weicloud.com>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, akpm@...ux-foundation.org,
mgorman@...hsingularity.net, david@...hat.com
Subject: Re: [PATCH 6/9] mm/compaction: rename is_via_compact_memory to
compaction_with_allocation_order
On 8/5/2023 7:07 PM, Kemeng Shi wrote:
> We have order = -1 via proactive compaction, the is_via_compact_memory is
> not proper name anymore.
> As cc->order informs the compaction to satisfy a allocation with that
> order, so rename it to compaction_with_allocation_order.
>
> Signed-off-by: Kemeng Shi <shikemeng@...weicloud.com>
> ---
> mm/compaction.c | 11 +++++------
> 1 file changed, 5 insertions(+), 6 deletions(-)
>
> diff --git a/mm/compaction.c b/mm/compaction.c
> index d8416d3dd445..b5a699ed526b 100644
> --- a/mm/compaction.c
> +++ b/mm/compaction.c
> @@ -2055,12 +2055,11 @@ static isolate_migrate_t isolate_migratepages(struct compact_control *cc)
> }
>
> /*
> - * order == -1 is expected when compacting via
> - * /proc/sys/vm/compact_memory
> + * compact to satisfy allocation with target order
> */
> -static inline bool is_via_compact_memory(int order)
> +static inline bool compaction_with_allocation_order(int order)
I know naming is hard, but this name is not good enough that can show
the compaction mode. But the original one could.
> {
> - return order == -1;
> + return order != -1;
> }
>
> /*
> @@ -2200,7 +2199,7 @@ static enum compact_result __compact_finished(struct compact_control *cc)
> goto out;
> }
>
> - if (is_via_compact_memory(cc->order))
> + if (!compaction_with_allocation_order(cc->order))
> return COMPACT_CONTINUE;
>
> /*
> @@ -2390,7 +2389,7 @@ compact_zone(struct compact_control *cc, struct capture_control *capc)
>
> cc->migratetype = gfp_migratetype(cc->gfp_mask);
>
> - if (!is_via_compact_memory(cc->order)) {
> + if (compaction_with_allocation_order(cc->order)) {
> unsigned long watermark;
>
> /* Allocation can already succeed, nothing to do */
Powered by blists - more mailing lists