[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <38158855-5738-16a9-2237-34980917566b@infradead.org>
Date: Wed, 16 Aug 2023 12:35:52 -0700
From: Randy Dunlap <rdunlap@...radead.org>
To: coolrrsh@...il.com, james.smart@...adcom.com,
ram.vegesna@...adcom.com, jejb@...ux.ibm.com,
martin.petersen@...cle.com, linux-scsi@...r.kernel.org,
target-devel@...r.kernel.org, linux-kernel@...r.kernel.org
Cc: linux-kernel-mentees@...ts.linuxfoundation.org
Subject: Re: [PATCH] scsi: sli4: Remove code duplication
Hi--
On 8/16/23 01:50, coolrrsh@...il.com wrote:
> From: Rajeshwar R Shinde <coolrrsh@...il.com>
>
> In the function sli_xmit_bls_rsp64_wqe, the 'if' and 'else' conditions
> evaluates the same expression and gives same output. So removing the redundant
> code duplication to optimise the code.
>
> This fixes warning such as:
> drivers/scsi/elx/libefc_sli/sli4.c:2320:2-4: WARNING: possible condition with no effect (if == else)
What tool produces this message?
> Signed-off-by: Rajeshwar R Shinde <coolrrsh@...il.com>
> ---
> drivers/scsi/elx/libefc_sli/sli4.c | 8 ++------
> 1 file changed, 2 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/scsi/elx/libefc_sli/sli4.c b/drivers/scsi/elx/libefc_sli/sli4.c
> index 8f96049f62dd..5e7fb110bc3f 100644
> --- a/drivers/scsi/elx/libefc_sli/sli4.c
> +++ b/drivers/scsi/elx/libefc_sli/sli4.c
> @@ -2317,12 +2317,8 @@ sli_xmit_bls_rsp64_wqe(struct sli4 *sli, void *buf,
> SLI4_GENERIC_CONTEXT_VPI << SLI4_BLS_RSP_WQE_CT_SHFT;
> bls->context_tag = cpu_to_le16(params->vpi);
>
> - if (params->s_id != U32_MAX)
> - bls->local_n_port_id_dword |=
> - cpu_to_le32(params->s_id & 0x00ffffff);
> - else
> - bls->local_n_port_id_dword |=
> - cpu_to_le32(params->s_id & 0x00ffffff);
> + bls->local_n_port_id_dword |=
> + cpu_to_le32(params->s_id & 0x00ffffff);
That could be correct. Or there could be a bug there.
Who knows? I don't.
But maybe it doesn't matter since AFAICT that field isn't used
anywhere after it is set.
>
> dw_ridflags = (dw_ridflags & ~SLI4_BLS_RSP_RID) |
> (params->d_id & SLI4_BLS_RSP_RID);
--
~Randy
Powered by blists - more mailing lists