[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <BL1PR12MB514444DF0C2E304A46DE0F4BF7E3A@BL1PR12MB5144.namprd12.prod.outlook.com>
Date: Fri, 25 Aug 2023 13:18:16 +0000
From: "Deucher, Alexander" <Alexander.Deucher@....com>
To: Sui Jingfeng <sui.jingfeng@...ux.dev>,
Bjorn Helgaas <bhelgaas@...gle.com>
CC: "alsa-devel@...a-project.org" <alsa-devel@...a-project.org>,
Sui Jingfeng <suijingfeng@...ngson.cn>,
"nouveau@...ts.freedesktop.org" <nouveau@...ts.freedesktop.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"dri-devel@...ts.freedesktop.org" <dri-devel@...ts.freedesktop.org>,
"amd-gfx@...ts.freedesktop.org" <amd-gfx@...ts.freedesktop.org>,
"linux-pci@...r.kernel.org" <linux-pci@...r.kernel.org>
Subject: RE: [PATCH 0/5] Add the pci_get_base_class() helper and use it
[Public]
> -----Original Message-----
> From: amd-gfx <amd-gfx-bounces@...ts.freedesktop.org> On Behalf Of Sui
> Jingfeng
> Sent: Friday, August 25, 2023 2:27 AM
> To: Bjorn Helgaas <bhelgaas@...gle.com>
> Cc: alsa-devel@...a-project.org; Sui Jingfeng <suijingfeng@...ngson.cn>;
> nouveau@...ts.freedesktop.org; linux-kernel@...r.kernel.org; dri-
> devel@...ts.freedesktop.org; amd-gfx@...ts.freedesktop.org; linux-
> pci@...r.kernel.org
> Subject: [PATCH 0/5] Add the pci_get_base_class() helper and use it
>
> From: Sui Jingfeng <suijingfeng@...ngson.cn>
>
> There is no function that can be used to get all PCI(e) devices in a system by
> matching against its the PCI base class code only, while keep the sub-class code
> and the programming interface ignored. Therefore, add the
> pci_get_base_class() function to suit the need.
>
> For example, if an application want to process all PCI(e) display devices in a
> system, it can achieve such goal by writing the code as following:
>
> pdev = NULL;
> do {
> pdev = pci_get_base_class(PCI_BASE_CLASS_DISPLAY, pdev);
> if (!pdev)
> break;
>
> do_something_for_pci_display_device(pdev);
> } while (1);
>
> Sui Jingfeng (5):
> PCI: Add the pci_get_base_class() helper
> ALSA: hda/intel: Use pci_get_base_class() to reduce duplicated code
> drm/nouveau: Use pci_get_base_class() to reduce duplicated code
> drm/amdgpu: Use pci_get_base_class() to reduce duplicated code
> drm/radeon: Use pci_get_base_class() to reduce duplicated code
>
Series is:
Reviewed-by: Alex Deucher <alexander.deucher@....com>
> drivers/gpu/drm/amd/amdgpu/amdgpu_acpi.c | 11 +++------
> drivers/gpu/drm/amd/amdgpu/amdgpu_bios.c | 20 ++++-----------
> drivers/gpu/drm/nouveau/nouveau_acpi.c | 11 +++------
> drivers/gpu/drm/radeon/radeon_bios.c | 20 ++++-----------
> drivers/pci/search.c | 31 ++++++++++++++++++++++++
> include/linux/pci.h | 5 ++++
> sound/pci/hda/hda_intel.c | 16 ++++--------
> 7 files changed, 59 insertions(+), 55 deletions(-)
>
> --
> 2.34.1
Powered by blists - more mailing lists