[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZO0DDkNUZ4FwYTrz@qmqm.qmqm.pl>
Date: Mon, 28 Aug 2023 22:26:54 +0200
From: Michał Mirosław <mirq-linux@...e.qmqm.pl>
To: Doug Anderson <dianders@...omium.org>
Cc: Liam Girdwood <lgirdwood@...il.com>,
Mark Brown <broonie@...nel.org>, linux-kernel@...r.kernel.org,
Dmitry Osipenko <digetx@...il.com>,
Stephen Boyd <swboyd@...omium.org>
Subject: Re: [PATCH 6/6] regulator: core: simplify lock_two()
On Mon, Aug 21, 2023 at 09:51:08AM -0700, Doug Anderson wrote:
> Hi,
>
> On Sat, Aug 19, 2023 at 3:46 PM Michał Mirosław <mirq-linux@...e.qmqm.pl> wrote:
> >
> > Make regulator_lock_two() shorter by observing that we have only two
> > locks and when swapped earlier the retry code becomes identical to the
> > normal (optimistic) path.
> >
> > Signed-off-by: Michał Mirosław <mirq-linux@...e.qmqm.pl>
> > ---
> > drivers/regulator/core.c | 28 ++++++++++------------------
> > 1 file changed, 10 insertions(+), 18 deletions(-)
>
> This is quite nearly a direct revert of commit 37473397b852
> ("regulator: core: Make regulator_lock_two() logic easier to follow"),
> which was requested by Stephen in:
>
> https://lore.kernel.org/r/CAE-0n53Eb1BeDPmjBycXUaQAF4ppiAM6UDWje_jiB9GAmR8MMw@mail.gmail.com
>
> I don't personally have a strong opinion, but do prefer not to flip-flop. ;-)
Indeed they are quite similar. I did remove a bit more code than that,
though: in this case there is no early success return before the loop.
Instead of saying:
lock A
lock B
if ok return
if that failed, loop:
unlock A
lock B harder
lock A
if ok return
swap A <-> B
lock B
Now it's:
lock A
loop forever:
lock B
if ok, return
unlock A
swap them
lock A harder
With the same condition 'A held' at the start of an iteration.
Best Regards
Michał Mirosław
Powered by blists - more mailing lists