[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230828170559.GW14596@pendragon.ideasonboard.com>
Date: Mon, 28 Aug 2023 20:05:59 +0300
From: Laurent Pinchart <laurent.pinchart@...asonboard.com>
To: Bryan O'Donoghue <bryan.odonoghue@...aro.org>
Cc: rfoss@...nel.org, todor.too@...il.com, agross@...nel.org,
andersson@...nel.org, konrad.dybcio@...aro.org, mchehab@...nel.org,
hverkuil-cisco@...all.nl, sakari.ailus@...ux.intel.com,
andrey.konovalov@...aro.org, linux-media@...r.kernel.org,
linux-arm-msm@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 2/9] media: qcom: camss: Fix V4L2 async notifier error
path
Hi Bryan,
Thank you for the patch.
On Tue, Aug 22, 2023 at 09:06:19PM +0100, Bryan O'Donoghue wrote:
> Previously the jump label err_cleanup was used higher in the probe()
> function to release the async notifier however the async notifier
> registration was moved later in the code rendering the previous four jumps
> redundant.
>
> Rename the label from err_cleanup to err_v4l2_device_register to capture
> what the jump does.
Shouldn't it be named err_v4l2_device_unregister then ? As the
err_register_subdevs label should also be renamed err_unregister_subdevs
you could rename them all in a separate patch.
> Fixes: 51397a4ec75d ("media: qcom: Initialise V4L2 async notifier later")
> Signed-off-by: Bryan O'Donoghue <bryan.odonoghue@...aro.org>
> ---
> drivers/media/platform/qcom/camss/camss.c | 16 ++++++++--------
> 1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/media/platform/qcom/camss/camss.c b/drivers/media/platform/qcom/camss/camss.c
> index 75991d849b571..f4948bdf3f8f9 100644
> --- a/drivers/media/platform/qcom/camss/camss.c
> +++ b/drivers/media/platform/qcom/camss/camss.c
> @@ -1617,21 +1617,21 @@ static int camss_probe(struct platform_device *pdev)
>
> ret = camss_icc_get(camss);
> if (ret < 0)
> - goto err_cleanup;
> + return ret;
>
> ret = camss_configure_pd(camss);
> if (ret < 0) {
> dev_err(dev, "Failed to configure power domains: %d\n", ret);
> - goto err_cleanup;
> + return ret;
> }
>
> ret = camss_init_subdevices(camss);
> if (ret < 0)
> - goto err_cleanup;
> + return ret;
>
> ret = dma_set_mask_and_coherent(dev, 0xffffffff);
> if (ret)
> - goto err_cleanup;
> + return ret;
This doesn't seem right, you should call v4l2_async_nf_cleanup() when
v4l2_async_nf_init() has been called, and that's done before
camss_icc_get().
>
> camss->media_dev.dev = camss->dev;
> strscpy(camss->media_dev.model, "Qualcomm Camera Subsystem",
> @@ -1643,7 +1643,7 @@ static int camss_probe(struct platform_device *pdev)
> ret = v4l2_device_register(camss->dev, &camss->v4l2_dev);
> if (ret < 0) {
> dev_err(dev, "Failed to register V4L2 device: %d\n", ret);
> - goto err_cleanup;
> + return ret;
> }
>
> v4l2_async_nf_init(&camss->notifier, &camss->v4l2_dev);
> @@ -1651,12 +1651,12 @@ static int camss_probe(struct platform_device *pdev)
> num_subdevs = camss_of_parse_ports(camss);
> if (num_subdevs < 0) {
> ret = num_subdevs;
> - goto err_cleanup;
> + goto err_v4l2_device_register;
> }
>
> ret = camss_register_entities(camss);
> if (ret < 0)
> - goto err_cleanup;
> + goto err_v4l2_device_register;
>
> if (num_subdevs) {
> camss->notifier.ops = &camss_subdev_notifier_ops;
> @@ -1690,7 +1690,7 @@ static int camss_probe(struct platform_device *pdev)
>
> err_register_subdevs:
> camss_unregister_entities(camss);
> -err_cleanup:
> +err_v4l2_device_register:
> v4l2_device_unregister(&camss->v4l2_dev);
> v4l2_async_nf_cleanup(&camss->notifier);
>
--
Regards,
Laurent Pinchart
Powered by blists - more mailing lists