[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAG_fn=XJ-fZTJPqrjcu2PVNzBvg8309M+jT4h_iGraYNN4APmA@mail.gmail.com>
Date: Wed, 30 Aug 2023 09:47:10 +0200
From: Alexander Potapenko <glider@...gle.com>
To: andrey.konovalov@...ux.dev
Cc: Marco Elver <elver@...gle.com>,
Andrey Konovalov <andreyknvl@...il.com>,
Dmitry Vyukov <dvyukov@...gle.com>,
Vlastimil Babka <vbabka@...e.cz>, kasan-dev@...glegroups.com,
Evgenii Stepanov <eugenis@...gle.com>,
Andrew Morton <akpm@...ux-foundation.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org,
Andrey Konovalov <andreyknvl@...gle.com>
Subject: Re: [PATCH 04/15] stackdepot: add depot_fetch_stack helper
On Tue, Aug 29, 2023 at 7:11 PM <andrey.konovalov@...ux.dev> wrote:
>
> From: Andrey Konovalov <andreyknvl@...gle.com>
>
> Add a helper depot_fetch_stack function that fetches the pointer to
> a stack record.
>
> With this change, all static depot_* functions now operate on stack pools
> and the exported stack_depot_* functions operate on the hash table.
>
> Signed-off-by: Andrey Konovalov <andreyknvl@...gle.com>
Reviewed-by: Alexander Potapenko <glider@...gle.com>
(one nit below)
> +static struct stack_record *depot_fetch_stack(depot_stack_handle_t handle)
> +{
> + union handle_parts parts = { .handle = handle };
> + /*
> + * READ_ONCE pairs with potential concurrent write in
> + * depot_alloc_stack.
Nit: please change to "depot_alloc_stack()" for consistency with the
rest of the comments.
Powered by blists - more mailing lists