[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <726d4be5-d207-4176-bc0d-43492eb2c4e5@linaro.org>
Date: Mon, 4 Sep 2023 01:40:49 +0300
From: Dmitry Baryshkov <dmitry.baryshkov@...aro.org>
To: Stephen Boyd <swboyd@...omium.org>,
Rob Clark <robdclark@...il.com>,
Abhinav Kumar <quic_abhinavk@...cinc.com>
Cc: linux-kernel@...r.kernel.org, patches@...ts.linux.dev,
Sean Paul <sean@...rly.run>, dri-devel@...ts.freedesktop.org,
freedreno@...ts.freedesktop.org,
Vinod Polimera <quic_vpolimer@...cinc.com>,
Kuogee Hsieh <quic_khsieh@...cinc.com>
Subject: Re: [PATCH 7/7] drm/msm/dp: Remove dp_display_is_ds_bridge()
On 29/08/2023 21:47, Stephen Boyd wrote:
> This function is simply drm_dp_is_branch() so use that instead of
> open-coding it.
>
> Cc: Vinod Polimera <quic_vpolimer@...cinc.com>
> Cc: Kuogee Hsieh <quic_khsieh@...cinc.com>
> Signed-off-by: Stephen Boyd <swboyd@...omium.org>
> ---
> drivers/gpu/drm/msm/dp/dp_display.c | 9 +--------
> 1 file changed, 1 insertion(+), 8 deletions(-)
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@...aro.org>
>
> diff --git a/drivers/gpu/drm/msm/dp/dp_display.c b/drivers/gpu/drm/msm/dp/dp_display.c
> index 76f13954015b..96bbf6fec2f1 100644
> --- a/drivers/gpu/drm/msm/dp/dp_display.c
> +++ b/drivers/gpu/drm/msm/dp/dp_display.c
> @@ -341,19 +341,12 @@ static const struct component_ops dp_display_comp_ops = {
> .unbind = dp_display_unbind,
> };
>
> -static bool dp_display_is_ds_bridge(struct dp_panel *panel)
> -{
> - return (panel->dpcd[DP_DOWNSTREAMPORT_PRESENT] &
> - DP_DWN_STRM_PORT_PRESENT);
> -}
> -
> static bool dp_display_is_sink_count_zero(struct dp_display_private *dp)
Nit: you might as well inline this function
> {
> drm_dbg_dp(dp->drm_dev, "present=%#x sink_count=%d\n",
> dp->panel->dpcd[DP_DOWNSTREAMPORT_PRESENT],
> dp->link->sink_count);
> - return dp_display_is_ds_bridge(dp->panel) &&
> - (dp->link->sink_count == 0);
> + return drm_dp_is_branch(dp->panel->dpcd) && dp->link->sink_count == 0;
> }
>
> static void dp_display_send_hpd_event(struct msm_dp *dp_display)
--
With best wishes
Dmitry
Powered by blists - more mailing lists