[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZPWjr7CP+WK064PI@smile.fi.intel.com>
Date: Mon, 4 Sep 2023 12:30:23 +0300
From: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To: Bartosz Golaszewski <brgl@...ev.pl>
Cc: Linus Walleij <linus.walleij@...aro.org>,
linux-gpio@...r.kernel.org, linux-kernel@...r.kernel.org,
Bartosz Golaszewski <bartosz.golaszewski@...aro.org>
Subject: Re: [PATCH 1/2] gpiolib: rename gpio_set_debounce_timeout() for
consistency
On Mon, Sep 04, 2023 at 12:24:53PM +0300, Andy Shevchenko wrote:
> On Mon, Sep 04, 2023 at 09:34:09AM +0200, Bartosz Golaszewski wrote:
> > From: Bartosz Golaszewski <bartosz.golaszewski@...aro.org>
> >
> > All other functions that manipulate a struct gpio_desc use the gpiod_
> > prefix. Follow this convention and rename gpio_set_debounce_timeout() to
> > gpiod_set_debounce_timeout().
>
> No, that's not true. This one is inline with the other gpio_set() _internal_
> APIs. If renamed, should be done consistently.
It's even broader, like for_each_gpio_desc(). So, looking at that one I would
rather use gpio_desc_ prefix / suffix than gpiod in case you are so eager to
rename (Personally I consider this as unneeded churn). Also consider going
thru all _internal_ APIs, like gpiod_not_found(), to be renamed to
gpio_desc_not_found().
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists