lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230905024835.43219-1-yangxingui@huawei.com>
Date:   Tue, 5 Sep 2023 02:48:32 +0000
From:   Xingui Yang <yangxingui@...wei.com>
To:     <jejb@...ux.ibm.com>, <martin.petersen@...cle.com>,
        <john.g.garry@...cle.com>, <damien.lemoal@...nsource.wdc.com>
CC:     <andriy.shevchenko@...ux.intel.com>, <akpm@...ux-foundation.org>,
        <viro@...iv.linux.org.uk>, <himanshu.madhani@...ium.com>,
        <felipe.balbi@...ux.intel.com>, <gregkh@...uxfoundation.org>,
        <uma.shankar@...el.com>, <anshuman.gupta@...el.com>,
        <animesh.manna@...el.com>, <linux-usb@...r.kernel.org>,
        <linux-scsi@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        <linuxarm@...wei.com>, <yangxingui@...wei.com>,
        <prime.zeng@...ilicon.com>, <kangfenglong@...wei.com>,
        <chenxiang66@...ilicon.com>
Subject: [PATCH v6 0/3] Add helper macro DEFINE_SHOW_STORE_ATTRIBUTE() at seq_file.c

We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper macro
for read-write file too.

So we add this helper macro to reduce duplicated code.

Changes from v5:
- Undelete the unused macros in qla_dfs.c and rewrite them using reference
  to the new macro on Andy's suggestion.
- Adjust some descriptions in commit based on Andy's suggestion.

Changes from v4:
- Reduce the scope to scsi subsystem based on Andy's suggestion.
- Remove unused macros in qla_dfs.c
- Adjust some descriptions in commit.

Changes from v3:
- Add AI Viro's comment to v1->v2's revision description.
- Fixed a spelling mistakes of "marco" to "macro".

Changes from v2:
- Fixed some spelling mistakes in commit.
- Revision description are added for easy tracing.

Changes from v1:
- Rename DEFINE_STORE_ATTRIBUTE() to DEFINE_SHOW_STORE_ATTRIBUTE().
- AI Viro points out that he doesn't like the definition of macros
  like DEFINE_SHOW_ATTRIBUTE.

Luo Jiaxing (3):
  seq_file: Add helper macro to define attribute for rw file
  scsi: hisi_sas: Use DEFINE_SHOW_STORE_ATTRIBUTE() helper for debugfs
  scsi: qla2xxx: Use DEFINE_SHOW_STORE_ATTRIBUTE() helper for debugfs

 drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 137 ++-----------------------
 drivers/scsi/qla2xxx/qla_dfs.c         |  59 ++---------
 include/linux/seq_file.h               |  15 +++
 3 files changed, 31 insertions(+), 180 deletions(-)

-- 
2.17.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ