[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKfTPtCt7m5c0y1ttF3k3coZ34fbALpAToK5vUpgtZVTPwNrzg@mail.gmail.com>
Date: Tue, 5 Sep 2023 15:50:34 +0200
From: Vincent Guittot <vincent.guittot@...aro.org>
To: Peter Zijlstra <peterz@...radead.org>
Cc: linux@...linux.org.uk, catalin.marinas@....com, will@...nel.org,
paul.walmsley@...ive.com, palmer@...belt.com,
aou@...s.berkeley.edu, sudeep.holla@....com,
gregkh@...uxfoundation.org, rafael@...nel.org, mingo@...hat.com,
juri.lelli@...hat.com, dietmar.eggemann@....com,
rostedt@...dmis.org, bsegall@...gle.com, mgorman@...e.de,
bristot@...hat.com, vschneid@...hat.com, viresh.kumar@...aro.org,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-riscv@...ts.infradead.org, linux-pm@...r.kernel.org,
conor.dooley@...rochip.com, suagrfillet@...il.com,
ajones@...tanamicro.com, lftan@...nel.org
Subject: Re: [PATCH 3/4] cpufreq/schedutil: use a fixed reference frequency
On Tue, 5 Sept 2023 at 13:25, Peter Zijlstra <peterz@...radead.org> wrote:
>
> On Fri, Sep 01, 2023 at 03:03:11PM +0200, Vincent Guittot wrote:
>
> > +#ifdef arch_scale_freq_ref
> > +/**
> > + * arch_scale_freq_ref_policy - get the reference frequency of a given CPU that
> > + * has been used to correlate frequency and compute capacity.
> > + * @cpu: the CPU in question.
> > + *
> > + * Return: the reference CPU frequency.
> > + */
> > +static __always_inline
> > +unsigned long arch_scale_freq_ref_policy(struct cpufreq_policy *policy)
> > +{
> > + return arch_scale_freq_ref(policy->cpu);
> > +}
> > +#else
> > +static __always_inline
> > +unsigned long arch_scale_freq_ref_policy(struct cpufreq_policy *policy)
>
> double space ^^
I was expecting checkpatch.pl to catch it
will fix them
>
> > +{
> > + if (arch_scale_freq_invariant())
> > + return policy->cpuinfo.max_freq;
> > +
> > +
>
> superfluous whitespace there.
>
> > + return policy->cur;
> > +}
> > +#endif
>
> static __always_inline
> unsigned long arch_scale_freq_ref_policy(struct cpufreq_policy *policy)
> {
> #ifdef arch_scale_freq_ref
> return arch_scale_freq_ref(policy->cpu);
> #endif
>
> if (arch_scale_freq_invariant())
> return policy->cpuinfo.max_freq;
>
> return policy->cur;
> }
>
> Would have the lot in a single function and possibly easier to read?
yes
>
> > +
> > /**
> > * get_next_freq - Compute a new frequency for a given cpufreq policy.
> > * @sg_policy: schedutil policy object to compute the new frequency for.
> > @@ -139,11 +164,11 @@ static void sugov_deferred_update(struct sugov_policy *sg_policy)
> > static unsigned int get_next_freq(struct sugov_policy *sg_policy,
> > unsigned long util, unsigned long max)
> > {
> > + unsigned int freq;
> > struct cpufreq_policy *policy = sg_policy->policy;
> > - unsigned int freq = arch_scale_freq_invariant() ?
> > - policy->cpuinfo.max_freq : policy->cur;
>
> Leave the variable below per the inverse christmas thing.
>
> >
> > util = map_util_perf(util);
> > + freq = arch_scale_freq_ref_policy(policy);
> > freq = map_util_freq(util, freq, max);
> >
> > if (freq == sg_policy->cached_raw_freq && !sg_policy->need_freq_update)
> > --
> > 2.34.1
> >
>
> _______________________________________________
> linux-riscv mailing list
> linux-riscv@...ts.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-riscv
Powered by blists - more mailing lists