[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230905063550.GAZPbMRuLizPxmRuHF@fat_crate.local>
Date: Tue, 5 Sep 2023 08:35:50 +0200
From: Borislav Petkov <bp@...en8.de>
To: Josh Poimboeuf <jpoimboe@...nel.org>
Cc: x86@...nel.org, linux-kernel@...r.kernel.org,
Peter Zijlstra <peterz@...radead.org>,
Babu Moger <babu.moger@....com>,
Paolo Bonzini <pbonzini@...hat.com>,
Sean Christopherson <seanjc@...gle.com>, David.Kaplan@....com,
Andrew Cooper <andrew.cooper3@...rix.com>,
Nikolay Borisov <nik.borisov@...e.com>,
gregkh@...uxfoundation.org, Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH v3 00/20] SRSO fixes/cleanups
On Mon, Sep 04, 2023 at 10:04:44PM -0700, Josh Poimboeuf wrote:
> v3:
> - drop kvm patches (to be picked up by Sean)
> - fix "no microcode, no microcode" printk
> - fix "Safe Ret" capitalization in documentation
> - fix chopped line in commit log
> - drop "x86/srso: Remove redundant X86_FEATURE_ENTRY_IBPB check" patch
>
> Josh Poimboeuf (20):
> x86/srso: Fix srso_show_state() side effect
> x86/srso: Set CPUID feature bits independently of bug or mitigation
> status
> x86/srso: Don't probe microcode in a guest
> x86/srso: Fix SBPB enablement for spec_rstack_overflow=off
> x86/srso: Fix SBPB enablement for (possible) future fixed HW
> x86/srso: Print actual mitigation if requested mitigation isn't
> possible
> x86/srso: Print mitigation for retbleed IBPB case
> x86/srso: Fix vulnerability reporting for missing microcode
> x86/srso: Fix unret validation dependencies
> x86/alternatives: Remove faulty optimization
> x86/srso: Improve i-cache locality for alias mitigation
> x86/srso: Unexport untraining functions
> x86/srso: Remove 'pred_cmd' label
> x86/bugs: Remove default case for fully switched enums
> x86/srso: Move retbleed IBPB check into existing 'has_microcode' code
> block
> x86/srso: Disentangle rethunk-dependent options
> x86/rethunk: Use SYM_CODE_START[_LOCAL]_NOALIGN macros
> x86/retpoline: Remove .text..__x86.return_thunk section
> x86/nospec: Refactor UNTRAIN_RET[_*]
> x86/calldepth: Rename __x86_return_skl() to call_depth_return_thunk()
>
> Documentation/admin-guide/hw-vuln/srso.rst | 24 ++-
> arch/x86/include/asm/nospec-branch.h | 69 ++++-----
> arch/x86/include/asm/processor.h | 2 -
> arch/x86/kernel/alternative.c | 8 -
> arch/x86/kernel/cpu/amd.c | 28 ++--
> arch/x86/kernel/cpu/bugs.c | 102 ++++++------
> arch/x86/kernel/vmlinux.lds.S | 10 +-
> arch/x86/lib/retpoline.S | 171 +++++++++++----------
> include/linux/objtool.h | 3 +-
> scripts/Makefile.vmlinux_o | 3 +-
> 10 files changed, 201 insertions(+), 219 deletions(-)
They all look good to me, thanks!
Acked-by: Borislav Petkov (AMD) <bp@...en8.de>
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette
Powered by blists - more mailing lists