[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230907110305.2096052-1-masahiroy@kernel.org>
Date: Thu, 7 Sep 2023 20:03:05 +0900
From: Masahiro Yamada <masahiroy@...nel.org>
To: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: linux-kernel@...r.kernel.org,
"Rafael J . Wysocki" <rafael@...nel.org>,
Andy Shevchenko <andy@...nel.org>,
Masahiro Yamada <masahiroy@...nel.org>
Subject: [PATCH] devres: rename the first parameter of devm_add_action_or_reset()
Fix a possible mistake in commit 410e7088e971 ("devres: Pass unique name
of the resource to devm_add_action_or_reset()").
The first parameter of devm_add_action_or_reset() is the associated
device. The name 'release' is confusing because it is often used for
dr_release_t in the devres context.
Rename it to 'dev'. No functional change intended.
Signed-off-by: Masahiro Yamada <masahiroy@...nel.org>
---
include/linux/device.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/device.h b/include/linux/device.h
index 56d93a1ffb7b..1fa0e9cb5e01 100644
--- a/include/linux/device.h
+++ b/include/linux/device.h
@@ -403,8 +403,8 @@ static inline int __devm_add_action_or_reset(struct device *dev, void (*action)(
return ret;
}
-#define devm_add_action_or_reset(release, action, data) \
- __devm_add_action_or_reset(release, action, data, #action)
+#define devm_add_action_or_reset(dev, action, data) \
+ __devm_add_action_or_reset(dev, action, data, #action)
/**
* devm_alloc_percpu - Resource-managed alloc_percpu
--
2.39.2
Powered by blists - more mailing lists