lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <027eb591-98c9-a6c2-698e-2206fb960d21@quicinc.com>
Date:   Mon, 11 Sep 2023 13:56:07 +0800
From:   Can Guo <quic_cang@...cinc.com>
To:     Manivannan Sadhasivam <manivannan.sadhasivam@...aro.org>,
        <jejb@...ux.ibm.com>, <martin.petersen@...cle.com>
CC:     <bvanassche@....org>, <avri.altman@....com>,
        <alim.akhtar@...sung.com>, <andersson@...nel.org>,
        <konrad.dybcio@...aro.org>, <linux-arm-msm@...r.kernel.org>,
        <linux-scsi@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        <quic_nitirawa@...cinc.com>
Subject: Re: [PATCH 2/2] scsi: ufs: ufs-qcom: Rename "hs_gear" to "phy_gear"


On 9/8/2023 10:53 PM, Manivannan Sadhasivam wrote:
> The "hs_gear" variable is used to cache the gear setting for the PHY that
> will be used during ufs_qcom_power_up_sequence(). But it creates ambiguity
> with the gear setting used by the ufshcd driver.
>
> So let's rename it to "phy_gear" to make it explicit that this variable
> caches the gear setting for the PHY.
>
> Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@...aro.org>
> ---
>   drivers/ufs/host/ufs-qcom.c | 14 +++++++-------
>   drivers/ufs/host/ufs-qcom.h |  2 +-
>   2 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/ufs/host/ufs-qcom.c b/drivers/ufs/host/ufs-qcom.c
> index ebb8054a3b3e..93a72d0a1751 100644
> --- a/drivers/ufs/host/ufs-qcom.c
> +++ b/drivers/ufs/host/ufs-qcom.c
> @@ -460,7 +460,7 @@ static int ufs_qcom_power_up_sequence(struct ufs_hba *hba)
>   		return ret;
>   	}
>   
> -	phy_set_mode_ext(phy, PHY_MODE_UFS_HS_B, host->hs_gear);
> +	phy_set_mode_ext(phy, PHY_MODE_UFS_HS_B, host->phy_gear);
>   
>   	/* power on phy - start serdes and phy's power and clocks */
>   	ret = phy_power_on(phy);
> @@ -910,12 +910,12 @@ static int ufs_qcom_pwr_change_notify(struct ufs_hba *hba,
>   		}
>   
>   		/*
> -		 * Update hs_gear only when the gears are scaled to a higher value. This is because,
> -		 * the PHY gear settings are backwards compatible and we only need to change the PHY
> -		 * settings while scaling to higher gears.
> +		 * Update phy_gear only when the gears are scaled to a higher value. This is
> +		 * because, the PHY gear settings are backwards compatible and we only need to
> +		 * change the PHY gear settings while scaling to higher gears.
>   		 */
> -		if (dev_req_params->gear_tx > host->hs_gear)
> -			host->hs_gear = dev_req_params->gear_tx;
> +		if (dev_req_params->gear_tx > host->phy_gear)
> +			host->phy_gear = dev_req_params->gear_tx;
>   
>   		/* enable the device ref clock before changing to HS mode */
>   		if (!ufshcd_is_hs_mode(&hba->pwr_info) &&
> @@ -1282,7 +1282,7 @@ static int ufs_qcom_init(struct ufs_hba *hba)
>   	 * Power up the PHY using the minimum supported gear (UFS_HS_G2).
>   	 * Switching to max gear will be performed during reinit if supported.
>   	 */
> -	host->hs_gear = UFS_HS_G2;
> +	host->phy_gear = UFS_HS_G2;
>   
>   	return 0;
>   
> diff --git a/drivers/ufs/host/ufs-qcom.h b/drivers/ufs/host/ufs-qcom.h
> index dc27395ecba1..8d8613eff959 100644
> --- a/drivers/ufs/host/ufs-qcom.h
> +++ b/drivers/ufs/host/ufs-qcom.h
> @@ -227,7 +227,7 @@ struct ufs_qcom_host {
>   
>   	struct gpio_desc *device_reset;
>   
> -	u32 hs_gear;
> +	u32 phy_gear;
>   
>   	int esi_base;
>   	bool esi_enabled;

Reviewed-by: Can Guo <quic_cang@...cinc.com>

Tested-by: Can Guo <quic_cang@...cinc.com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ