lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 28 Sep 2023 11:44:42 +0200
From:   Paolo Abeni <pabeni@...hat.com>
To:     Yajun Deng <yajun.deng@...ux.dev>, davem@...emloft.net,
        edumazet@...gle.com, kuba@...nel.org
Cc:     netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
        Alexander Lobakin <aleksander.lobakin@...el.com>
Subject: Re: [PATCH net-next v5] net/core: Introduce netdev_core_stats_inc()
 for trace

On Thu, 2023-09-28 at 17:21 +0800, Yajun Deng wrote:
> On 2023/9/28 16:23, Paolo Abeni wrote:
> > On Tue, 2023-09-19 at 21:55 +0800, Yajun Deng wrote:
> > > Although there is a kfree_skb_reason() helper function that can be used to
> > > find the reason why this skb is dropped, but most callers didn't increase
> > > one of rx_dropped, tx_dropped, rx_nohandler and rx_otherhost_dropped.
> > > 
> > > For the users, people are more concerned about why the dropped in ip
> > > is increasing.
> > > 
> > > Introduce netdev_core_stats_inc() for trace. Also, move dev_core_stats()
> > > and netdev_core_stats_alloc() to dev.c, as they are not called externally.
> > > 
> > > Signed-off-by: Yajun Deng <yajun.deng@...ux.dev>
> > > Suggested-by: Alexander Lobakin <aleksander.lobakin@...el.com>
> > > ---
> > > v5: Access the per cpu pointer before reach the relevant offset.
> > > v4: Introduce netdev_core_stats_inc() instead of export dev_core_stats_*_inc()
> > > v3: __cold should be added to the netdev_core_stats_alloc().
> > > v2: use __cold instead of inline in dev_core_stats().
> > > v1: https://lore.kernel.org/netdev/20230911082016.3694700-1-yajun.deng@linux.dev/
> > > ---
> > >   include/linux/netdevice.h | 21 ++++-----------------
> > >   net/core/dev.c            | 26 ++++++++++++++++++++++++--
> > >   2 files changed, 28 insertions(+), 19 deletions(-)
> > > 
> > > diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
> > > index db3d8429d50d..4c258d44c7d2 100644
> > > --- a/include/linux/netdevice.h
> > > +++ b/include/linux/netdevice.h
> > > @@ -4001,32 +4001,19 @@ static __always_inline bool __is_skb_forwardable(const struct net_device *dev,
> > >   	return false;
> > >   }
> > >   
> > > -struct net_device_core_stats __percpu *netdev_core_stats_alloc(struct net_device *dev);
> > > -
> > > -static inline struct net_device_core_stats __percpu *dev_core_stats(struct net_device *dev)
> > > -{
> > > -	/* This READ_ONCE() pairs with the write in netdev_core_stats_alloc() */
> > > -	struct net_device_core_stats __percpu *p = READ_ONCE(dev->core_stats);
> > > -
> > > -	if (likely(p))
> > > -		return p;
> > > -
> > > -	return netdev_core_stats_alloc(dev);
> > > -}
> > > +void netdev_core_stats_inc(struct net_device *dev, u32 offset);
> > >   
> > >   #define DEV_CORE_STATS_INC(FIELD)						\
> > >   static inline void dev_core_stats_##FIELD##_inc(struct net_device *dev)		\
> > >   {										\
> > > -	struct net_device_core_stats __percpu *p;				\
> > > -										\
> > > -	p = dev_core_stats(dev);						\
> > > -	if (p)									\
> > > -		this_cpu_inc(p->FIELD);						\
> > > +	netdev_core_stats_inc(dev,						\
> > > +			offsetof(struct net_device_core_stats, FIELD));		\
> > >   }
> > >   DEV_CORE_STATS_INC(rx_dropped)
> > >   DEV_CORE_STATS_INC(tx_dropped)
> > >   DEV_CORE_STATS_INC(rx_nohandler)
> > >   DEV_CORE_STATS_INC(rx_otherhost_dropped)
> > > +#undef DEV_CORE_STATS_INC
> > >   
> > >   static __always_inline int ____dev_forward_skb(struct net_device *dev,
> > >   					       struct sk_buff *skb,
> > > diff --git a/net/core/dev.c b/net/core/dev.c
> > > index 606a366cc209..4bc0161bc0d6 100644
> > > --- a/net/core/dev.c
> > > +++ b/net/core/dev.c
> > > @@ -10497,7 +10497,8 @@ void netdev_stats_to_stats64(struct rtnl_link_stats64 *stats64,
> > >   }
> > >   EXPORT_SYMBOL(netdev_stats_to_stats64);
> > >   
> > > -struct net_device_core_stats __percpu *netdev_core_stats_alloc(struct net_device *dev)
> > > +static __cold struct net_device_core_stats __percpu *netdev_core_stats_alloc(
> > > +		struct net_device *dev)
> > >   {
> > >   	struct net_device_core_stats __percpu *p;
> > >   
> > > @@ -10510,7 +10511,28 @@ struct net_device_core_stats __percpu *netdev_core_stats_alloc(struct net_device
> > >   	/* This READ_ONCE() pairs with the cmpxchg() above */
> > >   	return READ_ONCE(dev->core_stats);
> > >   }
> > > -EXPORT_SYMBOL(netdev_core_stats_alloc);
> > > +
> > > +static inline struct net_device_core_stats __percpu *netdev_core_stats(
> > > +		struct net_device *dev)
> > I'm sorry for the delayed feedback - conference and traveling in the
> > way.
> > 
> > It looks like the 'inline' keyword above is a left-over of a previous
> > revision? The compiler should generate the same code even without it,
> > right? If so, it should be better drop it.
> 
> 
> If so, should I merge netdev_core_stats and netdev_core_stats_inc 
> together, as it didn't called by others. Like:
> 
> void netdev_core_stats_inc(struct net_device *dev, u32 offset)
> {
>          /* This READ_ONCE() pairs with the write in 
> netdev_core_stats_alloc() */
>          struct net_device_core_stats __percpu *p = 
> READ_ONCE(dev->core_stats);
> 
>          if (unlikely(!p))
>                  p = netdev_core_stats_alloc(dev);
> 
>          if (p)
>                  (*(unsigned long *)((void *)this_cpu_ptr(p) + offset))++;
> }
> EXPORT_SYMBOL_GPL(netdev_core_stats_inc);

Makes sense to me. I initially thought the code would be more readable
with 2 separate functions, but the above LGTM.

Cheers,

Paolo

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ