[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZR5yTecBhCFsVOtQ@gmail.com>
Date: Thu, 5 Oct 2023 10:22:37 +0200
From: Ingo Molnar <mingo@...nel.org>
To: Brian Gerst <brgerst@...il.com>
Cc: linux-kernel@...r.kernel.org, x86@...nel.org,
Thomas Gleixner <tglx@...utronix.de>,
Borislav Petkov <bp@...en8.de>,
"H . Peter Anvin" <hpa@...or.com>,
Andy Lutomirski <luto@...nel.org>,
Mika Penttilä <mpenttil@...hat.com>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Uros Bizjak <ubizjak@...il.com>,
Denys Vlasenko <dvlasenk@...hat.com>,
Peter Zijlstra <peterz@...radead.org>,
Josh Poimboeuf <jpoimboe@...hat.com>
Subject: Re: [PATCH v2 0/6] x86: Clean up fast syscall return validation
* Brian Gerst <brgerst@...il.com> wrote:
> This patch set cleans up the tests done to determine if a fast syscall
> return instruction can be used to return to userspace. It converts the
> code to C, and refactors existing code to be more readable.
>
> v2:
> - Fix shift value for canonical RIP test and use
> __is_canonical_address()
>
> Brian Gerst (6):
> x86/entry/64: Remove obsolete comment on tracing vs. SYSRET
> x86/entry/64: Convert SYSRET validation tests to C
> x86/entry/compat: Combine return value test from syscall handler
> x86/entry/32: Convert do_fast_syscall_32() to bool return type
> x86/entry/32: Remove SEP test for SYSEXIT
> x86/entry/32: Clean up syscall fast exit tests
>
> arch/x86/entry/common.c | 99 +++++++++++++++++++++-----------
> arch/x86/entry/entry_32.S | 2 +-
> arch/x86/entry/entry_64.S | 68 +---------------------
> arch/x86/entry/entry_64_compat.S | 12 ++--
> arch/x86/include/asm/syscall.h | 6 +-
> 5 files changed, 77 insertions(+), 110 deletions(-)
Ok, so I've applied patches #1, #3, #4 and #5 to tip:x86/entry,
(ie. skipped #2 & #6 for now), as they look correct and are good
improvements. None of these four patches depend on the skipped
patches in some way I missed, correct?
As for #2, I looked at the before/after disassembly, and the new
C code in do_syscall_64() looked suboptimal on x86-64 defconfig,
if I was reading it right.
Mind re-evaluating that, and if you still think the C conversion
is a good idea, mind putting a before/after analysis of the
generated instructions into the changelog? This is our primary
system call return path after all.
Thanks,
Ingo
Powered by blists - more mailing lists