[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <fbe836a5-97c5-340e-3644-1b0e046d3fbb@kernel.org>
Date: Sat, 7 Oct 2023 03:37:51 +0900
From: Chanwoo Choi <chanwoo@...nel.org>
To: Sascha Hauer <s.hauer@...gutronix.de>,
linux-rockchip@...ts.infradead.org
Cc: linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-pm@...r.kernel.org, Heiko Stuebner <heiko@...ech.de>,
Kyungmin Park <kyungmin.park@...sung.com>,
MyungJoo Ham <myungjoo.ham@...sung.com>,
Will Deacon <will@...nel.org>,
Mark Rutland <mark.rutland@....com>, kernel@...gutronix.de,
Michael Riesch <michael.riesch@...fvision.net>,
Robin Murphy <robin.murphy@....com>,
Vincent Legoll <vincent.legoll@...il.com>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Conor Dooley <conor+dt@...nel.org>, devicetree@...r.kernel.org,
Sebastian Reichel <sebastian.reichel@...labora.com>
Subject: Re: [PATCH v7 15/26] PM / devfreq: rockchip-dfi: give variable a
better name
On 23. 7. 4. 18:32, Sascha Hauer wrote:
> struct dmc_count_channel::total counts the clock cycles of the DDR
> controller. Rename it accordingly to give the reader a better idea
> what this is about. While at it, at some documentation to struct
> dmc_count_channel.
>
> Reviewed-by: Sebastian Reichel <sebastian.reichel@...labora.com>
> Signed-off-by: Sascha Hauer <s.hauer@...gutronix.de>
> ---
> drivers/devfreq/event/rockchip-dfi.c | 19 ++++++++++++-------
> 1 file changed, 12 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/devfreq/event/rockchip-dfi.c b/drivers/devfreq/event/rockchip-dfi.c
> index 8a7af7c32ae0d..50e497455dc69 100644
> --- a/drivers/devfreq/event/rockchip-dfi.c
> +++ b/drivers/devfreq/event/rockchip-dfi.c
> @@ -46,9 +46,14 @@
> #define DDRMON_CH1_COUNT_NUM 0x3c
> #define DDRMON_CH1_DFI_ACCESS_NUM 0x40
>
> +/**
> + * struct dmc_count_channel - structure to hold counter values from the DDR controller
> + * @access: Number of read and write accesses
> + * @clock_cycles: DDR clock cycles
> + */
> struct dmc_count_channel {
> u32 access;
> - u32 total;
> + u32 clock_cycles;
> };
>
> struct dmc_count {
> @@ -150,7 +155,7 @@ static void rockchip_dfi_read_counters(struct rockchip_dfi *dfi, struct dmc_coun
> continue;
> count->c[i].access = readl_relaxed(dfi_regs +
> DDRMON_CH0_DFI_ACCESS_NUM + i * 20);
> - count->c[i].total = readl_relaxed(dfi_regs +
> + count->c[i].clock_cycles = readl_relaxed(dfi_regs +
> DDRMON_CH0_COUNT_NUM + i * 20);
> }
> }
> @@ -182,29 +187,29 @@ static int rockchip_dfi_get_event(struct devfreq_event_dev *edev,
> struct rockchip_dfi *dfi = devfreq_event_get_drvdata(edev);
> struct dmc_count count;
> struct dmc_count *last = &dfi->last_event_count;
> - u32 access = 0, total = 0;
> + u32 access = 0, clock_cycles = 0;
> int i;
>
> rockchip_dfi_read_counters(dfi, &count);
>
> /* We can only report one channel, so find the busiest one */
> for (i = 0; i < DMC_MAX_CHANNELS; i++) {
> - u32 a, t;
> + u32 a, c;
>
> if (!(dfi->channel_mask & BIT(i)))
> continue;
>
> a = count.c[i].access - last->c[i].access;
> - t = count.c[i].total - last->c[i].total;
> + c = count.c[i].clock_cycles - last->c[i].clock_cycles;
>
> if (a > access) {
> access = a;
> - total = t;
> + clock_cycles = c;
> }
> }
>
> edata->load_count = access * 4;
> - edata->total_count = total;
> + edata->total_count = clock_cycles;
>
> dfi->last_event_count = count;
>
Acked-by: Chanwoo Choi <cw00.choi@...sung.com>
--
Best Regards,
Samsung Electronics
Chanwoo Choi
Powered by blists - more mailing lists