[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87fs2mrqld.fsf@mail.lhotse>
Date: Sun, 08 Oct 2023 09:54:22 +1100
From: Michael Ellerman <mpe@...erman.id.au>
To: Andrew Morton <akpm@...ux-foundation.org>,
Ryan Roberts <ryan.roberts@....com>,
"Aneesh Kumar K.V" <aneesh.kumar@...ux.ibm.com>
Cc: Matthew Wilcox <willy@...radead.org>,
Yin Fengwei <fengwei.yin@...el.com>,
David Hildenbrand <david@...hat.com>,
Yu Zhao <yuzhao@...gle.com>,
Catalin Marinas <catalin.marinas@....com>,
Anshuman Khandual <anshuman.khandual@....com>,
Yang Shi <shy828301@...il.com>,
"Huang, Ying" <ying.huang@...el.com>, Zi Yan <ziy@...dia.com>,
Luis Chamberlain <mcgrof@...nel.org>,
Itaru Kitayama <itaru.kitayama@...il.com>,
"Kirill A. Shutemov" <kirill.shutemov@...ux.intel.com>,
John Hubbard <jhubbard@...dia.com>,
David Rientjes <rientjes@...gle.com>,
Vlastimil Babka <vbabka@...e.cz>,
Hugh Dickins <hughd@...gle.com>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linuxppc-dev@...ts.ozlabs.org
Subject: Re: [PATCH v6 4/9] mm: thp: Introduce anon_orders and
anon_always_mask sysfs files
Andrew Morton <akpm@...ux-foundation.org> writes:
> On Fri, 29 Sep 2023 12:44:15 +0100 Ryan Roberts <ryan.roberts@....com> wrote:
>
>> In preparation for adding support for anonymous large folios that are
>> smaller than the PMD-size, introduce 2 new sysfs files that will be used
>> to control the new behaviours via the transparent_hugepage interface.
>> For now, the kernel still only supports PMD-order anonymous THP, so when
>> reading back anon_orders, it will reflect that. Therefore there are no
>> behavioural changes intended here.
>
> powerpc strikes again. ARCH=powerpc allmodconfig:
>
>
> In file included from ./include/linux/bits.h:6,
> from ./include/linux/ratelimit_types.h:5,
> from ./include/linux/printk.h:9,
> from ./include/asm-generic/bug.h:22,
> from ./arch/powerpc/include/asm/bug.h:116,
> from ./include/linux/bug.h:5,
> from ./include/linux/mmdebug.h:5,
> from ./include/linux/mm.h:6,
> from mm/huge_memory.c:8:
> ./include/vdso/bits.h:7:33: error: initializer element is not constant
> 7 | #define BIT(nr) (UL(1) << (nr))
> | ^
> mm/huge_memory.c:77:47: note: in expansion of macro 'BIT'
> 77 | unsigned int huge_anon_orders __read_mostly = BIT(PMD_ORDER);
> | ^~~
>
> We keep tripping over this. I wish there was a way to fix it.
I can't think of any solution, other than ripping the code out.
To catch it earlier we'd need a generic compile-time test that all values
derived from the page table geometry are only used in places that don't
require a constant. I can't think of a way to write a test for that.
Or submitters could compile-test for powerpc - one can dream :D
> Style whine: an all-caps identifier is supposed to be a constant,
> dammit.
>
> #define PTE_INDEX_SIZE __pte_index_size
>
> Nope.
I agree it's ugly. It was done that way because PTE_INDEX_SIZE used to
be constant, and still is for 32-bit PPC and 64-bit Book3E PPC.
We could rename PTE_INDEX_SIZE itself, but we'd still have eg.
PTE_TABLE_SIZE which is used in generic code, and which would be
sometimes constant and sometimes not for different powerpc subarches.
> I did this:
>
> --- a/mm/huge_memory.c~mm-thp-introduce-anon_orders-and-anon_always_mask-sysfs-files-fix
> +++ a/mm/huge_memory.c
> @@ -74,7 +74,7 @@ static unsigned long deferred_split_scan
> static atomic_t huge_zero_refcount;
> struct page *huge_zero_page __read_mostly;
> unsigned long huge_zero_pfn __read_mostly = ~0UL;
> -unsigned int huge_anon_orders __read_mostly = BIT(PMD_ORDER);
> +unsigned int huge_anon_orders __read_mostly;
> static unsigned int huge_anon_always_mask __read_mostly;
>
> /**
> @@ -528,6 +528,9 @@ static int __init hugepage_init_sysfs(st
> {
> int err;
>
> + /* powerpc's PMD_ORDER isn't a compile-time constant */
> + huge_anon_orders = BIT(PMD_ORDER);
> +
> *hugepage_kobj = kobject_create_and_add("transparent_hugepage", mm_kobj);
> if (unlikely(!*hugepage_kobj)) {
> pr_err("failed to create transparent hugepage kobject\n");
> _
>
>
> I assume this is set up early enough.
Yes it should be.
> I don't know why powerpc's PTE_INDEX_SIZE is variable.
To allow a single vmlinux to boot using either the Hashed Page Table
MMU, or Radix Tree MMU, which have different page table geometry.
That's a pretty crucial feature for distros, so that they can build a
single kernel to boot on Power8/9/10.
cheers
Powered by blists - more mailing lists