[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <169701607495.2760941.7574229474626886892.kvalo@kernel.org>
Date: Wed, 11 Oct 2023 09:21:16 +0000 (UTC)
From: Kalle Valo <kvalo@...nel.org>
To: "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: Arend van Spriel <aspriel@...il.com>,
Franky Lin <franky.lin@...adcom.com>,
Hante Meuleman <hante.meuleman@...adcom.com>,
linux-wireless@...r.kernel.org,
brcm80211-dev-list.pdl@...adcom.com,
SHA-cyfmac-dev-list@...ineon.com, linux-kernel@...r.kernel.org,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH][next] wifi: brcmfmac: fweh: Add __counted_by for struct
brcmf_fweh_queue_item and use struct_size()
"Gustavo A. R. Silva" <gustavoars@...nel.org> wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time via CONFIG_UBSAN_BOUNDS (for
> array indexing) and CONFIG_FORTIFY_SOURCE (for strcpy/memcpy-family
> functions).
>
> Also, relocate `event->datalen = datalen;` to before calling
> `memcpy(event->data, data, datalen);`, so that the __counted_by
> annotation has effect, and flex-array member `data` can be properly
> bounds-checked at run-time.
>
> While there, use struct_size() helper, instead of the open-coded
> version, to calculate the size for the allocation of the whole
> flexible structure, including of course, the flexible-array member.
>
> This code was found with the help of Coccinelle, and audited and
> fixed manually.
>
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
> Reviewed-by: Kees Cook <keescook@...omium.org>
> Acked-by: Arend van Spriel <arend.vanspriel@...adcom.com>
Patch applied to wireless-next.git, thanks.
62d19b358088 wifi: brcmfmac: fweh: Add __counted_by for struct brcmf_fweh_queue_item and use struct_size()
--
https://patchwork.kernel.org/project/linux-wireless/patch/ZSRzrIe0345eymk2@work/
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
Powered by blists - more mailing lists