[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <arc5clw7z2avnt2tbw5mw6lvrj3kjebmuarju4uqc2hxtuv7ow@htiko7yh3oyf>
Date: Mon, 16 Oct 2023 11:59:52 -0700
From: Bjorn Andersson <andersson@...nel.org>
To: "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: Srinivas Kandagatla <srinivas.kandagatla@...aro.org>,
Banajit Goswami <bgoswami@...cinc.com>,
Andy Gross <agross@...nel.org>,
Konrad Dybcio <konrad.dybcio@...aro.org>,
alsa-devel@...a-project.org, linux-arm-msm@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org
Subject: Re: [PATCH][next] soc: qcom: apr: Add __counted_by for struct
apr_rx_buf and use struct_size()
On Mon, Oct 09, 2023 at 03:30:17PM -0600, Gustavo A. R. Silva wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time via CONFIG_UBSAN_BOUNDS (for
> array indexing) and CONFIG_FORTIFY_SOURCE (for strcpy/memcpy-family
> functions).
>
> While there, use struct_size() helper, instead of the open-coded
> version, to calculate the size for the allocation of the whole
> flexible structure, including of course, the flexible-array member.
>
> This code was found with the help of Coccinelle, and audited and
> fixed manually.
>
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
Applied, thanks.
> ---
> drivers/soc/qcom/apr.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/soc/qcom/apr.c b/drivers/soc/qcom/apr.c
> index 30f81d6d9d9d..1f8b315576a4 100644
> --- a/drivers/soc/qcom/apr.c
> +++ b/drivers/soc/qcom/apr.c
> @@ -41,7 +41,7 @@ struct packet_router {
> struct apr_rx_buf {
> struct list_head node;
> int len;
> - uint8_t buf[];
> + uint8_t buf[] __counted_by(len);
> };
>
> /**
> @@ -171,7 +171,7 @@ static int apr_callback(struct rpmsg_device *rpdev, void *buf,
> return -EINVAL;
> }
>
> - abuf = kzalloc(sizeof(*abuf) + len, GFP_ATOMIC);
> + abuf = kzalloc(struct_size(abuf, buf, len), GFP_ATOMIC);
> if (!abuf)
> return -ENOMEM;
>
> --
> 2.34.1
>
Powered by blists - more mailing lists