[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20231017061215.GB8454@lst.de>
Date: Tue, 17 Oct 2023 08:12:15 +0200
From: Christoph Hellwig <hch@....de>
To: Mark O'Donovan <shiftee@...teo.net>
Cc: linux-kernel@...r.kernel.org, linux-nvme@...ts.infradead.org,
sagi@...mberg.me, hch@....de, axboe@...nel.dk, kbusch@...nel.org,
hare@...e.de, Akash Appaiah <Akash.Appaiah@...l.com>
Subject: Re: [PATCH v3 2/3] nvme-auth: use transformed key size to create
resp
> +struct nvme_dhchap_key *nvme_auth_transform_key(struct nvme_dhchap_key *key, char *nqn)
Please avoid the overly long line.
> + key_len = sizeof(*key) + key->len;
struct_size again. And maybe add a helper to calculate the size for
a key instea dof duplicating it.
> + transformed_key = kmemdup(key, key_len, GFP_KERNEL);
> return transformed_key ? transformed_key : ERR_PTR(-ENOMEM);
Nit, but I find the ? : syntax very confusing when not used in things
like macros or argument lines. A
if (!transformed_key)
return ERR_PTR(-ENOMEM);
return transformed_key;
is a bit longer, but much easier to read.
> }
> hmac_name = nvme_auth_hmac_name(key->hash);
> @@ -257,7 +258,7 @@ u8 *nvme_auth_transform_key(struct nvme_dhchap_key *key, char *nqn)
>
> key_tfm = crypto_alloc_shash(hmac_name, 0, 0);
> if (IS_ERR(key_tfm))
> - return (u8 *)key_tfm;
> + return (void *)key_tfm;
This should (already in the original code) use ERR_CAST instead.
> + transformed_key = nvme_auth_transform_key(ctrl->host_key, ctrl->hostnqn);
Please avoid the overly long line here as well.
> +struct nvme_dhchap_key *nvme_auth_transform_key(struct nvme_dhchap_key *key, char *nqn);
... and here.
Powered by blists - more mailing lists