[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <2023101724-diagram-legwork-0e53@gregkh>
Date: Tue, 17 Oct 2023 09:50:50 +0200
From: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To: Dorcas AnonoLitunya <anonolitunya@...il.com>
Cc: outreachy@...ts.linux.dev, julia.lawall@...ia.fr,
dan.carpenter@...aro.org,
Sudip Mukherjee <sudipm.mukherjee@...il.com>,
Teddy Wang <teddy.wang@...iconmotion.com>,
linux-fbdev@...r.kernel.org, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 1/5] Staging: sm750fb: Rename
displayControlAdjust_SM750E
On Mon, Oct 16, 2023 at 11:14:08PM +0300, Dorcas AnonoLitunya wrote:
> Rename function displayControlAdjust_SM750E to
> display_control_adjust_SM750E. This follows snakecase naming convention
> and ensures a consistent naming style throughout the file. Issue found by
> checkpatch.
>
> Mutes the following error:
> CHECK:Avoid CamelCase: <displayControlAdjust_SM750E>
>
> Signed-off-by: Dorcas AnonoLitunya <anonolitunya@...il.com>
> ---
> drivers/staging/sm750fb/ddk750_mode.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/ddk750_mode.c b/drivers/staging/sm750fb/ddk750_mode.c
> index e00a6cb31947..8708995f676c 100644
> --- a/drivers/staging/sm750fb/ddk750_mode.c
> +++ b/drivers/staging/sm750fb/ddk750_mode.c
> @@ -14,8 +14,8 @@
> * in bit 29:27 of Display Control register.
> */
> static unsigned long
> -displayControlAdjust_SM750LE(struct mode_parameter *pModeParam,
> - unsigned long dispControl)
> +display_control_adjust_SM750LE(struct mode_parameter *pModeParam,
> + unsigned long dispControl)
> {
> unsigned long x, y;
>
> @@ -125,7 +125,7 @@ static int programModeRegisters(struct mode_parameter *pModeParam,
> tmp |= DISPLAY_CTRL_HSYNC_PHASE;
>
> if (sm750_get_chip_type() == SM750LE) {
> - displayControlAdjust_SM750LE(pModeParam, tmp);
> + display_control_adjust_SM750LE(pModeParam, tmp);
Why is this function returning a value if it is just being ignored?
It's not the issue here in the patch, but for future changes.
thanks,
greg k-h
Powered by blists - more mailing lists