lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 17 Oct 2023 18:16:18 -0700
From:   Sean Christopherson <seanjc@...gle.com>
To:     Sean Christopherson <seanjc@...gle.com>,
        Paolo Bonzini <pbonzini@...hat.com>,
        Mingwei Zhang <mizhang@...gle.com>
Cc:     "H. Peter Anvin" <hpa@...or.com>, kvm@...r.kernel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in()

On Tue, 17 Oct 2023 23:26:10 +0000, Mingwei Zhang wrote:
> Update the variable with name 'kvm' in kvm_x86_ops.sched_in() to 'vcpu' to
> avoid confusions. Variable naming in KVM has a clear convention that 'kvm'
> refers to pointer of type 'struct kvm *', while 'vcpu' refers to pointer of
> type 'struct kvm_vcpu *'.
> 
> Fix this 9-year old naming issue for fun.
> 
> [...]

Applied to kvm-x86 misc, thanks!

[1/1] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in()
      https://github.com/kvm-x86/linux/commit/5a989bbead4c

--
https://github.com/kvm-x86/linux/tree/next

Powered by blists - more mailing lists