lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 20 Oct 2023 14:52:07 +0000
From:   Miguel Luis <miguel.luis@...cle.com>
To:     Russell King <rmk+kernel@...linux.org.uk>
CC:     "linux-pm@...r.kernel.org" <linux-pm@...r.kernel.org>,
        "loongarch@...ts.linux.dev" <loongarch@...ts.linux.dev>,
        "linux-acpi@...r.kernel.org" <linux-acpi@...r.kernel.org>,
        "linux-arch@...r.kernel.org" <linux-arch@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "linux-arm-kernel@...ts.infradead.org" 
        <linux-arm-kernel@...ts.infradead.org>,
        "linux-riscv@...ts.infradead.org" <linux-riscv@...ts.infradead.org>,
        "kvmarm@...ts.linux.dev" <kvmarm@...ts.linux.dev>,
        "x86@...nel.org" <x86@...nel.org>,
        James Morse <james.morse@....com>,
        Salil Mehta <salil.mehta@...wei.com>,
        Jonathan Cameron <Jonathan.Cameron@...wei.com>,
        Jean-Philippe Brucker <jean-philippe@...aro.org>,
        "jianyong.wu@....com" <jianyong.wu@....com>,
        "justin.he@....com" <justin.he@....com>,
        "Rafael J. Wysocki" <rafael@...nel.org>,
        Len Brown <lenb@...nel.org>
Subject: Re: [PATCH] ACPI: Use the acpi_device_is_present() helper in more
 places

Hi Russell,

> On 20 Oct 2023, at 13:59, Russell King <rmk+kernel@...linux.org.uk> wrote:
> 
> From: James Morse <james.morse@....com>
> 
> acpi_device_is_present() checks the present or functional bits
> from the cached copy of _STA.
> 
> A few places open-code this check. Use the helper instead to
> improve readability.
> 
> Signed-off-by: James Morse <james.morse@....com>
> Reviewed-by: Jonathan Cameron <Jonathan.Cameron@...wei.com>
> Reviewed-by: Gavin Shan <gshan@...hat.com>
> Signed-off-by: Russell King (Oracle) <rmk+kernel@...linux.org.uk>
> ---
> Jonathan Cameron suggests "Pull this one out and send it upstream in
> advance of the rest" so let's do that. See
> https://lore.kernel.org/r/20230914130455.00004434@Huawei.com/
> 
> So, let's get this upstream to reduce the number of outstanding patches
> for aarch64 vcpu hotplug.
> 
> drivers/acpi/scan.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c
> index 691d4b7686ee..ed01e19514ef 100644
> --- a/drivers/acpi/scan.c
> +++ b/drivers/acpi/scan.c
> @@ -304,7 +304,7 @@ static int acpi_scan_device_check(struct acpi_device *adev)
> int error;
> 
> acpi_bus_get_status(adev);
> - if (adev->status.present || adev->status.functional) {
> + if (acpi_device_is_present(adev)) {
> /*
> * This function is only called for device objects for which
> * matching scan handlers exist.  The only situation in which
> @@ -338,7 +338,7 @@ static int acpi_scan_bus_check(struct acpi_device *adev, void *not_used)
> int error;
> 
> acpi_bus_get_status(adev);
> - if (!(adev->status.present || adev->status.functional)) {
> + if (!acpi_device_is_present(adev)) {

Reviewed-by: Miguel Luis <miguel.luis@...cle.com>

Thank you

Miguel

> acpi_scan_device_not_present(adev);
> return 0;
> }
> -- 
> 2.30.2
> 
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ