[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <654468cf-1563-4c1c-8c7c-076bc6dfbabf@citrix.com>
Date: Wed, 25 Oct 2023 08:52:50 +0100
From: Andrew Cooper <andrew.cooper3@...rix.com>
To: Peter Zijlstra <peterz@...radead.org>,
Pawan Gupta <pawan.kumar.gupta@...ux.intel.com>
Cc: Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>, x86@...nel.org,
"H. Peter Anvin" <hpa@...or.com>,
Josh Poimboeuf <jpoimboe@...nel.org>,
Andy Lutomirski <luto@...nel.org>,
Jonathan Corbet <corbet@....net>,
Sean Christopherson <seanjc@...gle.com>,
Paolo Bonzini <pbonzini@...hat.com>, tony.luck@...el.com,
ak@...ux.intel.com, tim.c.chen@...ux.intel.com,
linux-kernel@...r.kernel.org, linux-doc@...r.kernel.org,
kvm@...r.kernel.org,
Alyssa Milburn <alyssa.milburn@...ux.intel.com>,
Daniel Sneddon <daniel.sneddon@...ux.intel.com>,
antonio.gomez.iglesias@...ux.intel.com,
Alyssa Milburn <alyssa.milburn@...el.com>
Subject: Re: [RESEND][PATCH 1/6] x86/bugs: Add asm helpers for executing VERW
On 25/10/2023 8:22 am, Peter Zijlstra wrote:
> On Tue, Oct 24, 2023 at 11:28:18PM -0700, Pawan Gupta wrote:
>
>> With .text.entry section I am getting getting below warnings and an
>> error:
>>
>> -----------------------------------------------------------------
>> LD vmlinux.o
>> vmlinux.o: warning: objtool: .text.entry+0x0: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x40: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x80: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0xc0: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x100: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x140: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x180: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x1c0: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x200: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x240: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x280: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x2c0: unreachable instruction
>> vmlinux.o: warning: objtool: .text.entry+0x300: unreachable instruction
>> vmlinux.o: warning: objtool: .altinstr_replacement+0x2c: relocation to !ENDBR: .text.entry+0x0
>> vmlinux.o: warning: objtool: .altinstr_replacement+0x1c4: relocation to !ENDBR: .text.entry+0x0
>> vmlinux.o: warning: objtool: .altinstr_replacement+0x1d0: relocation to !ENDBR: .text.entry+0x0
>> vmlinux.o: warning: objtool: .altinstr_replacement+0x2d2: relocation to !ENDBR: .text.entry+0x80
>> vmlinux.o: warning: objtool: .altinstr_replacement+0x5d5: relocation to !ENDBR: .text.entry+0xc0
>> OBJCOPY modules.builtin.modinfo
>> GEN modules.builtin
>> MODPOST vmlinux.symvers
>> UPD include/generated/utsversion.h
>> CC init/version-timestamp.o
>> LD .tmp_vmlinux.kallsyms1
>> ld: error: unplaced orphan section `.text.entry' from `vmlinux.o'
>> make[2]: *** [scripts/Makefile.vmlinux:36: vmlinux] Error 1
>> -----------------------------------------------------------------
>>
>> ... because my config has CONFIG_LD_ORPHAN_WARN_LEVEL="error" and
>> objtool needs to be told about this entry.
>>
>> Do you think its worth fighting these warnings and error, or simply use
>> .rodata section for verw memory operand?
> I'm thinking you need to at the very least stay in a section that's
> actually still mapped with PTI :-)
Sorry. Xen and Linux have this section named opposite ways around.
> diff --git a/arch/x86/entry/entry.S b/arch/x86/entry/entry.S
> index bfb7bcb362bc..9eb2b532c92a 100644
> --- a/arch/x86/entry/entry.S
> +++ b/arch/x86/entry/entry.S
> @@ -20,3 +22,16 @@ SYM_FUNC_END(entry_ibpb)
> EXPORT_SYMBOL_GPL(entry_ibpb);
>
> .popsection
> +
> +.pushsection .entry.text, "ax"
> +
> +.align 64
> +SYM_CODE_START_NOALIGN(mds_verw_sel)
> + UNWIND_HINT_UNDEFINED
> + ANNOTATE_NOENDBR
> +1:
> + .word __KERNEL_DS
> + .skip 64 - (. - 1b), 0xcc
The 1 label aliases mds_verw_sel and this must remain like this for the
construct to work.
So instead of .skip, why not simply .align 64, 0xcc and get rid of the
1: label?
Do we have a suitably named constant cacheline size, rather than
opencoding 64?
> +SYM_CODE_END(mds_verw_sel);
Given that KVM needs it, this probably needs an EXPORT_SYMBOL_GPL() on it.
~Andrew
Powered by blists - more mailing lists