[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20231027091640.50d68251@collabora.com>
Date: Fri, 27 Oct 2023 09:16:40 +0200
From: Boris Brezillon <boris.brezillon@...labora.com>
To: Danilo Krummrich <dakr@...hat.com>
Cc: airlied@...il.com, daniel@...ll.ch, matthew.brost@...el.com,
christian.koenig@....com, faith.ekstrand@...labora.com,
luben.tuikov@....com, dri-devel@...ts.freedesktop.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH drm-misc-next v2] drm/sched: implement dynamic job-flow
control
Hi Danilo,
On Tue, 24 Oct 2023 00:57:47 +0200
Danilo Krummrich <dakr@...hat.com> wrote:
> > > +
> > > + /**
> > > + * @update_job_credits: Called once the scheduler is considering this
> > > + * job for execution.
> > > + *
> > > + * Drivers may use this to update the job's submission credits, which is
> > > + * useful to e.g. deduct the number of native fences which have been
> > > + * signaled meanwhile.
> > > + *
> > > + * The callback must either return the new number of submission credits
> > > + * for the given job, or zero if no update is required.
> >
> > Any reason for having this special zero-means-no-update case? I mean,
> > drivers could just return sched_job->submission_credits if nothing
> > changed, and that would simplify the semantics IMHO. Another option, if
>
> I think I just did this because I thought it's a clever way to get rid of the
> need to deal with zero-sized jobs, which do not make much sense. In
> drm_sched_job_init() passing a zero job size defaults to one, which I think is
> reasonable. Doing the same thing here is more likely to hide a bug. However, the
> same is probably true for 'zero means no update' though. Maybe we should just
> WARN() in such a case.
>
> > we want to avoid the sched_job->submission_credits assignment when
> > nothing changes would be to make it a void function and let it update
> > the sched_job->submission_credits directly.
>
> Sure, that's an option as well. However, I'd probably prefer the new job size to
> be the return value. Having to sanity check job->submission_credits afterwards
> isn't that nice either.
Uh, sorry for the late reply, I see you've sent a v3 already :-/. I keep
thinking it'd be simpler to make this a void function that updates
s_job->submission_credits directly. I also don't see the problem with
doing a sanity check on job->submission_credits. I mean, if the driver
is doing something silly, you can't do much to prevent it anyway,
except warn the user that something wrong has happened. If you want to
WARN_ON(job->submission_credits == 0 ||
job->submission_credits > job_old_submission_credits);
that's fine. But none of this sanity checking has to do with the
function prototype/semantics, and I'm still not comfortable with this 0
=> no-change. If there's no change, we should just leave
job->submission_credits unchanged (or return job->submission_credits)
instead of inventing a new special case.
Regards,
Boris
Powered by blists - more mailing lists