[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20231102042959.11816-2-W_Armin@gmx.de>
Date: Thu, 2 Nov 2023 05:29:57 +0100
From: Armin Wolf <W_Armin@....de>
To: jithu.joseph@...el.com, maurice.ma@...el.com, hdegoede@...hat.com,
markgross@...nel.org, ilpo.jarvinen@...ux.intel.com
Cc: Dell.Client.Kernel@...l.com, platform-driver-x86@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH 2/4] platform/x86: wmi: Add to_wmi_device() helper macro
Add a helper macro for WMI drivers to cast a device to
the corresponding WMI device. This should replace some
boilerplate code.
Signed-off-by: Armin Wolf <W_Armin@....de>
---
include/linux/wmi.h | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/include/linux/wmi.h b/include/linux/wmi.h
index 207544968268..8a643c39fcce 100644
--- a/include/linux/wmi.h
+++ b/include/linux/wmi.h
@@ -27,6 +27,14 @@ struct wmi_device {
bool setable;
};
+/**
+ * to_wmi_device() - Helper macro to cast a device to a wmi_device
+ * @device: device struct
+ *
+ * Cast a struct device to a struct wmi_device.
+ */
+#define to_wmi_device(device) container_of(device, struct wmi_device, dev)
+
extern acpi_status wmidev_evaluate_method(struct wmi_device *wdev,
u8 instance, u32 method_id,
const struct acpi_buffer *in,
--
2.39.2
Powered by blists - more mailing lists