[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <f71e7e27-83ef-476b-baa6-bb82ea73db10@redhat.com>
Date: Thu, 2 Nov 2023 09:54:11 +0100
From: David Hildenbrand <david@...hat.com>
To: Vishal Verma <vishal.l.verma@...el.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Oscar Salvador <osalvador@...e.de>,
Dan Williams <dan.j.williams@...el.com>,
Dave Jiang <dave.jiang@...el.com>
Cc: linux-kernel@...r.kernel.org, linux-mm@...ck.org,
nvdimm@...ts.linux.dev, linux-cxl@...r.kernel.org,
Huang Ying <ying.huang@...el.com>,
Dave Hansen <dave.hansen@...ux.intel.com>,
"Aneesh Kumar K.V" <aneesh.kumar@...ux.ibm.com>,
Michal Hocko <mhocko@...e.com>,
Jonathan Cameron <Jonathan.Cameron@...wei.com>,
Jeff Moyer <jmoyer@...hat.com>
Subject: Re: [PATCH v8 2/3] mm/memory_hotplug: split memmap_on_memory requests
across memblocks
On 01.11.23 23:51, Vishal Verma wrote:
> The MHP_MEMMAP_ON_MEMORY flag for hotplugged memory is restricted to
> 'memblock_size' chunks of memory being added. Adding a larger span of
> memory precludes memmap_on_memory semantics.
>
> For users of hotplug such as kmem, large amounts of memory might get
> added from the CXL subsystem. In some cases, this amount may exceed the
> available 'main memory' to store the memmap for the memory being added.
> In this case, it is useful to have a way to place the memmap on the
> memory being added, even if it means splitting the addition into
> memblock-sized chunks.
>
> Change add_memory_resource() to loop over memblock-sized chunks of
> memory if caller requested memmap_on_memory, and if other conditions for
> it are met. Teach try_remove_memory() to also expect that a memory
> range being removed might have been split up into memblock sized chunks,
> and to loop through those as needed.
>
> This does preclude being able to use PUD mappings in the direct map; a
> proposal to how this could be optimized in the future is laid out
> here[1].
>
> [1]: https://lore.kernel.org/linux-mm/b6753402-2de9-25b2-36e9-eacd49752b19@redhat.com/
>
> Cc: Andrew Morton <akpm@...ux-foundation.org>
> Cc: David Hildenbrand <david@...hat.com>
> Cc: Michal Hocko <mhocko@...e.com>
> Cc: Oscar Salvador <osalvador@...e.de>
> Cc: Dan Williams <dan.j.williams@...el.com>
> Cc: Dave Jiang <dave.jiang@...el.com>
> Cc: Dave Hansen <dave.hansen@...ux.intel.com>
> Cc: Huang Ying <ying.huang@...el.com>
> Suggested-by: David Hildenbrand <david@...hat.com>
> Reviewed-by: Dan Williams <dan.j.williams@...el.com>
> Signed-off-by: Vishal Verma <vishal.l.verma@...el.com>
> ---
> mm/memory_hotplug.c | 213 ++++++++++++++++++++++++++++++++++------------------
> 1 file changed, 138 insertions(+), 75 deletions(-)
>
> diff --git a/mm/memory_hotplug.c b/mm/memory_hotplug.c
> index 6be7de9efa55..d242e49d7f7b 100644
> --- a/mm/memory_hotplug.c
> +++ b/mm/memory_hotplug.c
> @@ -1380,6 +1380,84 @@ static bool mhp_supports_memmap_on_memory(unsigned long size)
> return arch_supports_memmap_on_memory(vmemmap_size);
> }
>
> +static void __ref remove_memory_blocks_and_altmaps(u64 start, u64 size)
> +{
> + unsigned long memblock_size = memory_block_size_bytes();
> + u64 cur_start;
> +
> + /*
> + * For memmap_on_memory, the altmaps were added on a per-memblock
> + * basis; we have to process each individual memory block.
> + */
> + for (cur_start = start; cur_start < start + size;
> + cur_start += memblock_size) {
> + struct vmem_altmap *altmap = NULL;
> + struct memory_block *mem;
> +
> + mem = find_memory_block(pfn_to_section_nr(PFN_DOWN(cur_start)));
> + WARN_ON_ONCE(!mem);
> + if (!mem)
> + continue;
Nit:
if (WARN_ON_ONCE(!mem))
continue;
> + for (cur_start = start; cur_start < start + size;
> + cur_start += memblock_size) {
> + struct mhp_params params = { .pgprot =
> + pgprot_mhp(PAGE_KERNEL) };
> + struct vmem_altmap mhp_altmap = {
> + .base_pfn = PHYS_PFN(cur_start),
> + .end_pfn = PHYS_PFN(cur_start + memblock_size - 1),
> + };
> +
> + mhp_altmap.free = memory_block_memmap_on_memory_pages();
> + params.altmap = kmemdup(&mhp_altmap, sizeof(struct vmem_altmap),
> + GFP_KERNEL);
> + if (!params.altmap)
> + return -ENOMEM;
As already spotted, we have to cleanup.
> +
> + /* call arch's memory hotadd */
> + ret = arch_add_memory(nid, cur_start, memblock_size, ¶ms);
> + if (ret < 0) {
> + kfree(params.altmap);
> + goto out;
> + }
> +
> + /* create memory block devices after memory was added */
> + ret = create_memory_block_devices(cur_start, memblock_size,
> + params.altmap, group);
> + if (ret) {
> + arch_remove_memory(cur_start, memblock_size, NULL);
> + kfree(params.altmap);
> + goto out;
> + }
> + }
> +
> + return 0;
> +out:
> + if (ret && (cur_start != start))
Nit: I think you can drop the inner parentheses.
> @@ -2146,11 +2208,31 @@ void try_offline_node(int nid)
> }
> EXPORT_SYMBOL(try_offline_node);
>
> +static int memory_blocks_have_altmaps(u64 start, u64 size)
> +{
> + u64 num_memblocks = size / memory_block_size_bytes();
> + u64 num_altmaps = 0;
> +
> + if (!mhp_memmap_on_memory())
> + return 0;
> +
> + walk_memory_blocks(start, size, &num_altmaps,
> + count_memory_range_altmaps_cb);
> +
> + if (num_altmaps == 0)
> + return 0;
> +
> + if (num_memblocks != num_altmaps) {
> + WARN_ONCE(1, "Not all memblocks in range have altmaps");
Nit:
if (WARN_ON_ONCE(num_memblocks != num_altmaps))
return -EINVAL;
Should be sufficient.
[...]
> /* remove memmap entry */
> firmware_map_remove(start, start + size, "System RAM");
>
> - /*
> - * Memory block device removal under the device_hotplug_lock is
> - * a barrier against racing online attempts.
> - */
> - remove_memory_block_devices(start, size);
> -
> mem_hotplug_begin();
>
> - arch_remove_memory(start, size, altmap);
> -
> - /* Verify that all vmemmap pages have actually been freed. */
> - if (altmap) {
> - WARN(altmap->alloc, "Altmap not fully unmapped");
> - kfree(altmap);
> + rc = memory_blocks_have_altmaps(start, size);
> + if (rc < 0) {
> + goto err;
Nit: Maybe better to just
if (rc < 0) {
mem_hotplug_done();
return rc
} else ...
And avoid the error label below. Makes the code easier to read.
> + } else if (rc == 0) {
Nit: else if (!rc)
With the cleanup fixed,
Acked-by: David Hildenbrand <david@...hat.com>
--
Cheers,
David / dhildenb
Powered by blists - more mailing lists