[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZU4wA9xhfjYBCaTU@hovoldconsulting.com>
Date: Fri, 10 Nov 2023 14:28:35 +0100
From: Johan Hovold <johan@...nel.org>
To: Krishna Kurapati <quic_kriskura@...cinc.com>
Cc: Thinh Nguyen <Thinh.Nguyen@...opsys.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Philipp Zabel <p.zabel@...gutronix.de>,
Andy Gross <agross@...nel.org>,
Bjorn Andersson <andersson@...nel.org>,
Konrad Dybcio <konrad.dybcio@...aro.org>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Felipe Balbi <balbi@...nel.org>,
Wesley Cheng <quic_wcheng@...cinc.com>,
Mathias Nyman <mathias.nyman@...el.com>,
linux-usb@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-msm@...r.kernel.org, devicetree@...r.kernel.org,
quic_pkondeti@...cinc.com, quic_ppratap@...cinc.com,
quic_jackp@...cinc.com, ahalaney@...hat.com,
quic_shazhuss@...cinc.com,
Bjorn Andersson <quic_bjorande@...cinc.com>,
Rob Herring <robh@...nel.org>
Subject: Re: [PATCH v11 02/13] dt-bindings: usb: Add bindings for multiport
properties on DWC3 controller
On Mon, Aug 28, 2023 at 07:00:22PM +0530, Krishna Kurapati wrote:
> Add bindings to indicate properties required to support multiport
> on Synopsys DWC3 controller.
>
> Suggested-by: Bjorn Andersson <quic_bjorande@...cinc.com>
> Signed-off-by: Krishna Kurapati <quic_kriskura@...cinc.com>
> Reviewed-by: Rob Herring <robh@...nel.org>
> ---
> .../devicetree/bindings/usb/snps,dwc3.yaml | 13 +++++++------
> 1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/usb/snps,dwc3.yaml b/Documentation/devicetree/bindings/usb/snps,dwc3.yaml
> index a696f23730d3..5bc941355b43 100644
> --- a/Documentation/devicetree/bindings/usb/snps,dwc3.yaml
> +++ b/Documentation/devicetree/bindings/usb/snps,dwc3.yaml
> @@ -85,15 +85,16 @@ properties:
>
> phys:
> minItems: 1
> - maxItems: 2
> + maxItems: 8
>
> phy-names:
> minItems: 1
> - maxItems: 2
> - items:
> - enum:
> - - usb2-phy
> - - usb3-phy
> + maxItems: 8
> + oneOf:
> + - items:
> + enum: [ usb2-phy, usb3-phy ]
> + - items:
> + pattern: "^usb[23]-port[0-3]$"
Shouldn't this just be
pattern: "^usb[23]-[0-3]$"
so that it matches the names that are used by the nvidia bindings?
We already have some inconsistency in that Amlogic uses a variant based
on the legacy names that needlessly includes "phy" in the names:
const: usb2-phy0
const: usb2-phy1
const: usb3-phy0
...
I don't think we should be introducing a third naming scheme here so I
suggest just following the nvidia bindings.
Johan
Powered by blists - more mailing lists