lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 11 Nov 2023 09:52:21 +0100
From:   Benjamin Tissoires <benjamin.tissoires@...hat.com>
To:     David Revoy <davidrevoy@...tonmail.com>
Cc:     José Expósito <jose.exposito89@...il.com>,
        Eric GOUYER <folays@...il.com>,
        Illia Ostapyshyn <ostapyshyn@....uni-hannover.de>,
        jkosina@...e.cz, jason.gerecke@...om.com,
        linux-input@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: Requesting your attention and expertise regarding a Tablet/Kernel issue

Hi David,

On Thu, Nov 9, 2023 at 11:04 PM David Revoy <davidrevoy@...tonmail.com> wrote:
>
> Hi Benjamin,
>
> Thank you it works! 🎉 🎉 🎉
>
> > I've pushed an update of the file[0], turns out I made several mistakes.
> > As a general rule of thumb, you can follow the MR I've opened at [1],
> > click on the pipeline, open the last job ("make release"), then browse
> > the artifacts and pull the file from there.
> > [...]
> > > But just to be sure, you don't have a custom configuration in place
> > > for that tablet device?
> > [...]
> > [0] https://gitlab.freedesktop.org/libevdev/udev-hid-bpf/-/jobs/51399392/artifacts/file/udev-hid-bpf_0.1.0.tar.xz
> > [1] https://gitlab.freedesktop.org/libevdev/udev-hid-bpf/-/merge_requests/27
>
> I tested the latest artifact on kernel 6.5.8-200.fc38.x86_64 and I also removed my custom configuration at startup (I had not much: an hwdb files for the 24 Pro −mainly for frame buttons− and an xsetwacom bash script for each tablet).
>
> During the tests, the styluses of both 24 Pro and 16 Pro Gen2 worked perfectly: right-click on upper button out-of-the-box, and the eraser tip of the 16 Pro Gen2 continued to erase as expected.

While polishing the patches yesterday I realized that there was a bug
on the 24 Pro: it would never send proximity out events unless on a
very specific case: if you hold the pen perfectly vertical. This might
have an effect on the session and the pen behavior.

Could you please once again attach the hid-recorder of the Pro 24
while doing the following sequence:
- touch with the tip of the stylus the tablet
- while touching, press the upper button (the problematic one)
- still while touching, release the button
- remove the stylus

I need it to check what the device is sending when an "eraser mode
button" is pressed while the tip is touching the surface. Because I
think that's the only one problematic proximity out event as it would
"break" the current touch.

I have created another MR[2] to fix that, and I would appreciate it if
you could also give a test of the artifacts of job 51469284[3].

The points to check are:
- if you right click while touching the surface, do you still get only
a right click or some weird glitches in addition to it?
- if you right click while not touching (hovering), no glitches?

Cheers,
Benjamin

>
> I could also target with xsetwacom this 'button 3' of the styluses, and I tested random available shortcuts (but I'll keep default right-click).
>
> So, good job, and many thanks!
>
> I want now to write a follow-up after the first blog-post. I see it is a MR [1], maybe it means if it get merged it will be part of libevdev? What would you advice to write for the ones who want to benefit from the fix?
>
> Thanks again,
> David
>
> [1] https://gitlab.freedesktop.org/libevdev/udev-hid-bpf/-/merge_requests/27
>

[2] https://gitlab.freedesktop.org/libevdev/udev-hid-bpf/-/merge_requests/30
[3] https://gitlab.freedesktop.org/libevdev/udev-hid-bpf/-/jobs/51469284

Powered by blists - more mailing lists