lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 14 Nov 2023 15:18:33 +0100
From:   Peter Zijlstra <peterz@...radead.org>
To:     Borislav Petkov <bp@...en8.de>
Cc:     Juergen Gross <jgross@...e.com>, linux-kernel@...r.kernel.org,
        x86@...nel.org, Thomas Gleixner <tglx@...utronix.de>,
        Ingo Molnar <mingo@...hat.com>,
        Dave Hansen <dave.hansen@...ux.intel.com>,
        "H. Peter Anvin" <hpa@...or.com>
Subject: Re: [PATCH v4 2/5] x86/alternative: add indirect call patching

On Tue, Nov 14, 2023 at 02:47:15PM +0100, Borislav Petkov wrote:
> On Tue, Nov 14, 2023 at 01:50:28PM +0100, Peter Zijlstra wrote:
> > This loads the function target from the pv_ops table. We can't otherwise
> > do this.
> 
> On Tue, Nov 14, 2023 at 01:56:37PM +0100, Juergen Gross wrote:
> > It is replacing an _indirect_ call with a _direct_ one, taking the
> > call target from the pointer used by the indirect call.
> 
> Then this is not just a ALT_FLAG_CALL. This is something special. The
> flag definition needs a better name along with an explanation what it
> does, perhaps best with an example from the final vmlinux - not from the
> object file:
> 
> call   *0x0(%rip)
> 
> ==>
> 
> call   *0x0
> 
> where the offsets haven't been linked in yet.

Well, a random absolute address isn't going to be any better or worse
than 0. But perhaps adding the relocation as a comment helps?


   ff 15 00 00 00 00       call   *0x0(%rip)  #  R_X86_64_PC32    pv_ops+0x4
into:
   e8 00 00 00 00 90	   call   +0          #  R_X86_64_PC32 *(pv_ops+0x04)


> If this is going into the generic infrastructure, then it better be
> explained properly so that other stuff can potentially use it too.

ALT_FLAG_DEREFERENCE_INDIRECT_CALL ?

I'm going to already raise my hand and say that's too long ;-)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ