[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20231115160852.GDZVTtFHB0+HpVZnpG@fat_crate.local>
Date: Wed, 15 Nov 2023 17:08:52 +0100
From: Borislav Petkov <bp@...en8.de>
To: Michael Roth <michael.roth@....com>
Cc: kvm@...r.kernel.org, linux-coco@...ts.linux.dev,
linux-mm@...ck.org, linux-crypto@...r.kernel.org, x86@...nel.org,
linux-kernel@...r.kernel.org, tglx@...utronix.de, mingo@...hat.com,
jroedel@...e.de, thomas.lendacky@....com, hpa@...or.com,
ardb@...nel.org, pbonzini@...hat.com, seanjc@...gle.com,
vkuznets@...hat.com, jmattson@...gle.com, luto@...nel.org,
dave.hansen@...ux.intel.com, slp@...hat.com, pgonda@...gle.com,
peterz@...radead.org, srinivas.pandruvada@...ux.intel.com,
rientjes@...gle.com, dovmurik@...ux.ibm.com, tobin@....com,
vbabka@...e.cz, kirill@...temov.name, ak@...ux.intel.com,
tony.luck@...el.com, marcorr@...gle.com,
sathyanarayanan.kuppuswamy@...ux.intel.com, alpergun@...gle.com,
jarkko@...nel.org, ashish.kalra@....com, nikunj.dadhania@....com,
pankaj.gupta@....com, liam.merwick@...cle.com,
zhi.a.wang@...el.com, Brijesh Singh <brijesh.singh@....com>
Subject: Re: [PATCH v10 08/50] x86/fault: Add helper for dumping RMP entries
On Mon, Oct 16, 2023 at 08:27:37AM -0500, Michael Roth wrote:
> +/*
> + * Dump the raw RMP entry for a particular PFN. These bits are documented in the
> + * PPR for a particular CPU model and provide useful information about how a
> + * particular PFN is being utilized by the kernel/firmware at the time certain
> + * unexpected events occur, such as RMP faults.
> + */
> +static void sev_dump_rmpentry(u64 dumped_pfn)
Just "dump_rmentry"
s/dumped_pfn/pfn/g
> + struct rmpentry e;
> + u64 pfn, pfn_end;
> + int level, ret;
> + u64 *e_data;
> +
> + ret = __snp_lookup_rmpentry(dumped_pfn, &e, &level);
> + if (ret) {
> + pr_info("Failed to read RMP entry for PFN 0x%llx, error %d\n",
> + dumped_pfn, ret);
> + return;
> + }
> +
> + e_data = (u64 *)&e;
> + if (e.assigned) {
> + pr_info("RMP entry for PFN 0x%llx: [high=0x%016llx low=0x%016llx]\n",
> + dumped_pfn, e_data[1], e_data[0]);
> + return;
> + }
> +
> + /*
> + * If the RMP entry for a particular PFN is not in an assigned state,
> + * then it is sometimes useful to get an idea of whether or not any RMP
> + * entries for other PFNs within the same 2MB region are assigned, since
> + * those too can affect the ability to access a particular PFN in
> + * certain situations, such as when the PFN is being accessed via a 2MB
> + * mapping in the host page table.
> + */
> + pfn = ALIGN(dumped_pfn, PTRS_PER_PMD);
> + pfn_end = pfn + PTRS_PER_PMD;
> +
> + while (pfn < pfn_end) {
> + ret = __snp_lookup_rmpentry(pfn, &e, &level);
> + if (ret) {
> + pr_info_ratelimited("Failed to read RMP entry for PFN 0x%llx\n", pfn);
Why ratelmited?
No need to print anything if you fail to read it - simply dump the range
[pfn, pfn_end], _data[0], e_data[1] exactly *once* before the loop and
inside the loop dump only the ones you can lookup...
> + pfn++;
> + continue;
> + }
> +
> + if (e_data[0] || e_data[1]) {
> + pr_info("No assigned RMP entry for PFN 0x%llx, but the 2MB region contains populated RMP entries, e.g.: PFN 0x%llx: [high=0x%016llx low=0x%016llx]\n",
> + dumped_pfn, pfn, e_data[1], e_data[0]);
> + return;
> + }
> + pfn++;
> + }
> +
> + pr_info("No populated RMP entries in the 2MB region containing PFN 0x%llx\n",
> + dumped_pfn);
... and then you don't need this one either.
> +}
> +
> +void sev_dump_hva_rmpentry(unsigned long hva)
> +{
> + unsigned int level;
> + pgd_t *pgd;
> + pte_t *pte;
> +
> + pgd = __va(read_cr3_pa());
> + pgd += pgd_index(hva);
> + pte = lookup_address_in_pgd(pgd, hva, &level);
If this is using the current CR3, why aren't you simply using
lookup_address() here without the need to read pgd?
> +
> + if (pte) {
if (!pte)
Doh.
> + pr_info("Can't dump RMP entry for HVA %lx: no PTE/PFN found\n", hva);
> + return;
> + }
> +
> + sev_dump_rmpentry(pte_pfn(*pte));
> +}
> +EXPORT_SYMBOL_GPL(sev_dump_hva_rmpentry);
Who's going to use this, kvm?
--
Regards/Gruss,
Boris.
https://people.kernel.org/tglx/notes-about-netiquette
Powered by blists - more mailing lists