[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5165bc9f-4e57-bdda-0640-d6cdcd08f031@intel.com>
Date: Fri, 17 Nov 2023 10:18:35 +0100
From: Przemek Kitszel <przemyslaw.kitszel@...el.com>
To: Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>,
<saeedm@...dia.com>
CC: <leon@...nel.org>, <davem@...emloft.net>, <edumazet@...gle.com>,
<kuba@...nel.org>, <pabeni@...hat.com>, <netdev@...r.kernel.org>,
<linux-rdma@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
Abaci Robot <abaci@...ux.alibaba.com>
Subject: Re: [PATCH] net/mlx5: DR, Use swap() instead of open coding it
On 11/17/23 08:19, Jiapeng Chong wrote:
> Swap is a function interface that provides exchange function. To avoid
> code duplication, we can use swap function.
>
> ./drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c:1254:50-51: WARNING opportunity for swap().
>
> Reported-by: Abaci Robot <abaci@...ux.alibaba.com>
> Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=7580
> Signed-off-by: Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>
> ---
> .../net/ethernet/mellanox/mlx5/core/steering/dr_action.c | 8 ++------
> 1 file changed, 2 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> index e3ec559369fa..6f9790e97fed 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> @@ -1170,7 +1170,6 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
> bool ignore_flow_level,
> u32 flow_source)
> {
> - struct mlx5dr_cmd_flow_destination_hw_info tmp_hw_dest;
> struct mlx5dr_cmd_flow_destination_hw_info *hw_dests;
> struct mlx5dr_action **ref_actions;
> struct mlx5dr_action *action;
> @@ -1249,11 +1248,8 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
> * one that done in the TX.
> * So, if one of the ft target is wire, put it at the end of the dest list.
> */
> - if (is_ft_wire && num_dst_ft > 1) {
> - tmp_hw_dest = hw_dests[last_dest];
> - hw_dests[last_dest] = hw_dests[num_of_dests - 1];
> - hw_dests[num_of_dests - 1] = tmp_hw_dest;
> - }
> + if (is_ft_wire && num_dst_ft > 1)
> + swap(hw_dests[last_dest], hw_dests[num_of_dests - 1]);
>
> action = dr_action_create_generic(DR_ACTION_TYP_FT);
> if (!action)
Reviewed-by: Przemek Kitszel <przemyslaw.kitszel@...el.com>
For future non-bugfix contributions please target patches to net-next
Powered by blists - more mailing lists