[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20231118023232.1409103-1-wangkefeng.wang@huawei.com>
Date: Sat, 18 Nov 2023 10:32:27 +0800
From: Kefeng Wang <wangkefeng.wang@...wei.com>
To: Andrew Morton <akpm@...ux-foundation.org>
CC: <linux-kernel@...r.kernel.org>, <linux-mm@...ck.org>,
Matthew Wilcox <willy@...radead.org>,
David Hildenbrand <david@...hat.com>,
Sidhartha Kumar <sidhartha.kumar@...cle.com>,
Vishal Moola <vishal.moola@...il.com>,
Kefeng Wang <wangkefeng.wang@...wei.com>
Subject: [PATCH v3 0/5] mm: cleanup and use more folio in page fault
Rename page_copy_prealloc() to folio_prealloc(), which is used by
more functions, also do more folio conversion in page fault.
v3:
- drop patch6 as Small-sized THP for anon will change anon allocation
- correct do_cow_page to do_cow_fault in subject and changlog
- add RB of Vishal
v2:
- add folio_test_large check in ksm_might_need_to_copy() and
replace page->index to folio->index, per David, Matthew
- add RB of Sidhartha
Kefeng Wang (5):
mm: ksm: use more folio api in ksm_might_need_to_copy()
mm: memory: use a folio in validate_page_before_insert()
mm: memory: rename page_copy_prealloc() to folio_prealloc()
mm: memory: use a folio in do_cow_fault()
mm: memory: use folio_prealloc() in wp_page_copy()
include/linux/ksm.h | 4 ++--
mm/ksm.c | 39 ++++++++++++++++--------------
mm/memory.c | 58 +++++++++++++++++++++------------------------
3 files changed, 50 insertions(+), 51 deletions(-)
--
2.27.0
Powered by blists - more mailing lists