[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20231121-josef-generic-163-v1-0-049e37185841@wdc.com>
Date: Tue, 21 Nov 2023 08:32:29 -0800
From: Johannes Thumshirn <johannes.thumshirn@....com>
To: Chris Mason <clm@...com>, Josef Bacik <josef@...icpanda.com>,
David Sterba <dsterba@...e.com>
Cc: linux-btrfs@...r.kernel.org, linux-kernel@...r.kernel.org,
Christoph Hellwig <hch@....de>,
Naohiro Aota <Naohiro.Aota@....com>,
Johannes Thumshirn <johannes.thumshirn@....com>
Subject: [PATCH 0/5] btrfs: zoned: remove extent_buffer redirtying
Since the beginning of zoned mode, I've promised Josef to get rid of the
extent_buffer redirtying, but never actually got around to doing so.
Then 2 weeks ago our CI has hit an ASSERT() in this area and I started to look
into it again. After some discussion with Christoph we came to the conclusion
to finally take the time and get rid of the extent_buffer redirtying once and
for all.
Patch one renames EXTENT_BUFFER_NO_CHECK into EXTENT_BUFFER_CANCELLED, because
this fits the new model somewhat better.
Number two sets the cancel bit instead of clearing the dirty bit from a zoned
extent_buffer.
Number three removes the last remaining bits of btrfs_redirty_list_add().
The last two patches in this series are just trivial cleanups I came across
while looking at the code.
---
Johannes Thumshirn (5):
btrfs: rename EXTENT_BUFFER_NO_CHECK to EXTENT_BUFFER_CANCELLED
btrfs: zoned: don't clear dirty flag of extent buffer
btrfs: remove now unneeded btrfs_redirty_list_add
btrfs: use memset_page instead of opencoding it
btrfs: reflow btrfs_free_tree_block
fs/btrfs/disk-io.c | 4 +-
fs/btrfs/extent-tree.c | 102 ++++++++++++++++++++++++-------------------------
fs/btrfs/extent_io.c | 9 +++--
fs/btrfs/extent_io.h | 3 +-
fs/btrfs/tree-log.c | 1 -
fs/btrfs/zoned.c | 16 --------
fs/btrfs/zoned.h | 5 ---
7 files changed, 60 insertions(+), 80 deletions(-)
---
base-commit: 592afe8e8b7ceee58107757fd29ff3290e6539e3
change-id: 20231120-josef-generic-163-f4df4eab2c98
Best regards,
--
Johannes Thumshirn <johannes.thumshirn@....com>
Powered by blists - more mailing lists