lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 28 Nov 2023 17:38:15 +0300
From:   Dan Carpenter <dan.carpenter@...aro.org>
To:     Gary Rookard <garyrookard@...tmail.org>
Cc:     gregkh@...uxfoundation.org, philipp.g.hortmann@...il.com,
        linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 1/3] staging: rtl8192e: renamed variable nMcsRate

On Tue, Nov 28, 2023 at 09:20:25AM -0500, Gary Rookard wrote:
> v2: Renamed from CamelCase to Snake case the variable nMcsRate, and
> additionally removed the Hungarian notation of (n) that [v1] did not.
> nMcsRate -> mcs_rate
> 
> Linux kernel coding style (cleanup), checkpatch Avoid CamelCase.
> Driver/module rtl8192e compiles.
> 
> Signed-off-by: Gary Rookard <garyrookard@...tmail.org>
> ---
> v2: Removes Hungarian notation.
> v1: Renames from CamelCase only, Hungarian notation unremoved.
> 
>  drivers/staging/rtl8192e/rtl819x_HTProc.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/staging/rtl8192e/rtl819x_HTProc.c b/drivers/staging/rtl8192e/rtl819x_HTProc.c
> index 00273d709f3c..4ed72936eb4a 100644
> --- a/drivers/staging/rtl8192e/rtl819x_HTProc.c
> +++ b/drivers/staging/rtl8192e/rtl819x_HTProc.c
> @@ -103,7 +103,7 @@ void ht_update_default_setting(struct rtllib_device *ieee)
>  	ht_info->rx_reorder_pending_time = 30;
>  }
>  
> -static u16 ht_mcs_to_data_rate(struct rtllib_device *ieee, u8 nMcsRate)
> +static u16 ht_mcs_to_data_rate(struct rtllib_device *ieee, u8 mcs_rate)

In the caller, this variable is called mcsRate, which presumably
checkpatch also complains about.  Why not rename them both to the same
thing?

It's unclear what value adding the "mcs_" prefix has, but I guess it's
nice to have a consistent variable name to grep for.

regards,
dan carpenter

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ