[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <f5ba61c7-aae8-407c-90e9-4d6d9316d33d@kernel.dk>
Date: Mon, 4 Dec 2023 11:40:59 -0700
From: Jens Axboe <axboe@...nel.dk>
To: Yury Norov <yury.norov@...il.com>, linux-kernel@...r.kernel.org,
linux-block@...r.kernel.org
Cc: Jan Kara <jack@...e.cz>,
Mirsad Todorovac <mirsad.todorovac@....unizg.hr>,
Matthew Wilcox <willy@...radead.org>,
Rasmus Villemoes <linux@...musvillemoes.dk>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Maxim Kuvyrkov <maxim.kuvyrkov@...aro.org>,
Alexey Klimov <klimov.linux@...il.com>,
Bart Van Assche <bvanassche@....org>,
Sergey Shtylyov <s.shtylyov@....ru>
Subject: Re: [PATCH v2 03/35] lib/sbitmap; make __sbitmap_get_word() using
find_and_set_bit()
On 12/3/23 12:32 PM, Yury Norov wrote:
> diff --git a/lib/sbitmap.c b/lib/sbitmap.c
> index d0a5081dfd12..b21aebd07fd6 100644
> --- a/lib/sbitmap.c
> +++ b/lib/sbitmap.c
> @@ -133,38 +133,11 @@ void sbitmap_resize(struct sbitmap *sb, unsigned int depth)
> }
> EXPORT_SYMBOL_GPL(sbitmap_resize);
>
> -static int __sbitmap_get_word(unsigned long *word, unsigned long depth,
> +static inline int __sbitmap_get_word(unsigned long *word, unsigned long depth,
> unsigned int hint, bool wrap)
> {
> - int nr;
> -
> - /* don't wrap if starting from 0 */
> - wrap = wrap && hint;
> -
> - while (1) {
> - nr = find_next_zero_bit(word, depth, hint);
> - if (unlikely(nr >= depth)) {
> - /*
> - * We started with an offset, and we didn't reset the
> - * offset to 0 in a failure case, so start from 0 to
> - * exhaust the map.
> - */
> - if (hint && wrap) {
> - hint = 0;
> - continue;
> - }
> - return -1;
> - }
> -
> - if (!test_and_set_bit_lock(nr, word))
> - break;
> -
> - hint = nr + 1;
> - if (hint >= depth - 1)
> - hint = 0;
> - }
> -
> - return nr;
> + return wrap ? find_and_set_bit_wrap_lock(word, depth, hint) :
> + find_and_set_next_bit_lock(word, depth, hint);
> }
Please make this:
if (wrap)
return find_and_set_bit_wrap_lock(word, depth, hint) :
return find_and_set_next_bit_lock(word, depth, hint);
so this is a lot more readable.
--
Jens Axboe
Powered by blists - more mailing lists