[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20231207195613.153980-1-tony.luck@intel.com>
Date: Thu, 7 Dec 2023 11:56:10 -0800
From: Tony Luck <tony.luck@...el.com>
To: Fenghua Yu <fenghua.yu@...el.com>,
Reinette Chatre <reinette.chatre@...el.com>,
Peter Newman <peternewman@...gle.com>,
Jonathan Corbet <corbet@....net>,
Shuah Khan <skhan@...uxfoundation.org>, x86@...nel.org
Cc: Shaopeng Tan <tan.shaopeng@...itsu.com>,
James Morse <james.morse@....com>,
Jamie Iles <quic_jiles@...cinc.com>,
Babu Moger <babu.moger@....com>,
Randy Dunlap <rdunlap@...radead.org>,
linux-kernel@...r.kernel.org, linux-doc@...r.kernel.org,
patches@...ts.linux.dev, Tony Luck <tony.luck@...el.com>
Subject: [PATCH v6 0/3] x86/resctrl: mba_MBps enhancements
Two changes relating to the MBA Software Controller(mba_sc):
1) Add a new mount option so the user can choose which memory
bandwidth monitoring event to use as the input to the feedback
loop.
2) Update the "mba_MBps" mount option to make use of total memory
bandwidth event on systems that do not support local bandwidth
event.
Signed-off-by: Tony Luck <tony.luck@...el.com>
---
Changes since v5:
Babu: Split into separate patches for the new mount option and the
update to the exising mount option. Since this is now a series, I
also moved the Documentation change to its own patch.
Reinette: Use "mbm_local_bytes", "mbm_total_bytes" as the strings for
the new "mba_MBps_event" option. This sets a precedent that new events
should follow the naming convention for the monitor files for the event.
Reinette: Update rdtgroup_show_options(). I'd completely missed this in
the earlier versions. Note that when the legacy "mba_MBps" mount option
is used, this will show in /proc as if the new option was used:
# mount -t resctrl -o mba_MBps resctrl /sys/fs/resctrl/
# grep resctrl /proc/mounts
resctrl /sys/fs/resctrl resctrl rw,relatime,mba_MBps_event=mbm_local_bytes 0 0
Changing this to exacly match what the user typed would lose the detail
of which event is being used.
Reinette: More documentation needed. I added some text on why using
total instead of local might be useful to some users.
Tony Luck (3):
x86/resctrl: Add mount option "mba_MBps_event"
x86/resctrl: Use total bandwidth for mba_MBps option when local isn't
present
x86/resctrl: Add new "mba_MBps_event" mount option to documentation
Documentation/arch/x86/resctrl.rst | 16 ++++++-
include/linux/resctrl.h | 2 +
arch/x86/kernel/cpu/resctrl/internal.h | 3 +-
arch/x86/kernel/cpu/resctrl/monitor.c | 21 ++++-----
arch/x86/kernel/cpu/resctrl/rdtgroup.c | 63 +++++++++++++++++++++-----
5 files changed, 79 insertions(+), 26 deletions(-)
base-commit: 33cc938e65a98f1d29d0a18403dbbee050dcad9a
--
2.41.0
Powered by blists - more mailing lists